My Jeep Compass Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello; I bought a 2007 jeep compass which has a few irregularities. When I leave it parked for more than a day or so the battery is drained. I've swapped out the battery, same result. There is a remote starter installed which I've never been able to get functioning, and they had an after market stereo installed. Previous owner says they could never find the source of the drain to the battery.

thoughts?
 

·
Registered
Joined
·
82 Posts
Wondering if the alternator is the problem? Or perhaps it isn't able to produce enough power to keep up with the vehicle's demand. Maybe the two installed components are defective and that is sucking lots of juice.

Best to bring it to a garage.
 

·
Registered
Joined
·
272 Posts
I'd disconnect any wiring having for the remote starter first, see if the problem still happens, then disconnect the stereo (if the problem still occurs) and see the results. If it's not the alternator, then theres definitely a device that's draining constant power.

How long do you typically let the battery build back up after you presumably boost it?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
If I drive the car daily it seems to hold a charge. If I leave it for more than a day I have to put it on a charger or the thing is drained. I know its been into a garage more than once by the original owner, looking for the trouble. I would like to keep the remote starter, but frankly it doesnt work anyway, so I think disconnecting it would be the most logical first step.

I will try this and repost to let the forum know how I make out. Thanks for the suggestions.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Well, thanks for the advice, it seems to have been the remote starter. I removed it, and the car is running like a champ.
Now, the next gremlin on the list is the signal.
The right turn signal starts as a slow flash then the dash chimes and the signal speeds up. The intensity of the bulb is about half of that of the left turn signal. I have replaced all the bulbs on the right side, both front and back, but the situation is the same.

Any thoughts, o geniuses of the Jeep?

thanks again for your help.

Plankton
 
1 - 5 of 5 Posts
Top