My Jeep Compass Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I'm a newbie here but hoping I can get some DIY help.

I have a 2007 Compass Limited 2.4L 4WD 175k. It been running just fine and a couple of weeks ago my wife called and said she was roadside and the Compass would shift into drive and reverse and you could feel it engage but when pressing the gas the RPMs went up but the Jeep didn't move.

Just a few weeks before this it was going into limp mode and the ABS, EPS, BAS, and 4WD lights came on. Had the codes pulled and pointed to rear wheel sensors. I hadn't gotten around to fix them yet.

So I had then Jeep towed back home, replaced the rear hub/breaing assemblies and wheel speed sensors.

However, I still have the problem CVT problem of being able to shift into drive or reverse but the jeep does NOT move anywhere.

Anyone have any clues or can provide any advice on what could be the problem?

Thanks in advance!
Chad
 

·
Registered
Joined
·
1 Posts
Curious if you ever got this sorted?
My daughter just bought a used 2007 Compass and had this same problem. I'm trying to remotely diagnose and i have no idea whats going on with it.
 

·
Moderator
Joined
·
1,117 Posts
Might the CVT be low on fluid? I don't know about all those indicator lights, but the unresponsive transmission would typically indicate low fluid in a conventional automatic so I'm thinking it may be the same with a CVT. I had a 2008 Patriot with the CVT and a couple times it got low on fluid. Both times covered under warranty. Unfortunately there is no way to check the fluid on a CVT -- its a sealed unit. You'll probably have to visit a dealer or qualified shop.
 
1 - 4 of 4 Posts
Top