My Jeep Compass Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Yesterday I was driving in the city and my ABS suddenly kicked in, the roads were wet but not enough to engage the ABS. Then when I tried to accelerate, the traction control light started flashing and the car would not accelerate. Then, it stopped and the car drove normally for a few minutes. Then my dashboard lit up, ESP, ABS and 4x4 lights all on. Got home and attached my code reader. It said, " Right front ABS Speed Sensor Erratic Behavior." When I started the car again later that day, and drove it for a 1/4 mile all the lights went off. Drove normally until this afternoon. Started down the road and all the lights came on again. Took it back home and parked it. Went to start it again this evening and my Electronic Throttle Control light started flashing, with the idle revving. Shut the car off, attached the code reader again, now it is giving me code P000B, Camshaft position Slow response Bank 1. I have no idea if these problems are related or just happening at the same time. Replaced the ABS Speed sensor about a year ago, along with the wheel bearings. I always change the oil on time and always use the correct oil. Any input would be helpful. Are all of these problems related?
 

·
Registered
Joined
·
82 Posts
P000B should mean slow response from the cam sensor. It can be cause from dirty oil or the wrong type of oil. If the oil is right, then the problem may lay with the cam sensor or cam sensor solenoid. Have you tried taking your Compass in for a checkup?
 

·
Registered
Joined
·
1 Posts
4WD warning

I just bought my compass a month ago and this same thing happened. What was cause, did you get it fixed and how much?

Thank you
 
1 - 4 of 4 Posts
Top