My Jeep Compass Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
I have an odd problem with a recently acquired 2007 Compass Limited. The MIL is lit and my Innova code reader errors out on trying to link. The Innova works fine on every other vehicle I have so I don't think it's the reader. Kinda surprised to see it only had contacts in pins 4,5,6, 14 & 16. I verified 12v at pin 16 and pin 5 is grounded. I just now see that I needed to verify pin 4 as grounded so that remains a wildcard in this. I'll have to go back and check that but the wiring and overall condition is good, this thing doesn't appear to have been beat on. It otherwise runs/drives fine but I'll need to fix the MIL to pass emissions. Anyone see something like this before?

Confirmed pin 4 is grounded
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Solved. The code reader was too old. Bought a new one and obtained the codes. FWIW, if you get codes P2010 and P0032 along with the AC not being cold, it's probably a ground issue. For me, it was ground G110 which is located on the passenger side frame rail under the coolant reservoir. It visually looked ok with some minor corrosion but once I opened the two claws that wrap around the ground wire. Once I did that, several smaller wires fell out. They had been severed at the connector but the claws made it all look okay. Spiced some wires into a separate connector and put it all back together. Cleared the codes and all was good.
 
1 - 2 of 2 Posts
Top