My Jeep Compass Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi, I have an '07 Jeep Compass, about 105,000 miles on it.

It runs completely fine when my foot is on the gas, and when in park. However, when I come to a stop such as a stoplight, it has a rough idle. So much so that it eventually starts to shudder, shakes the whole front end and then stalls out completely. Starts up completely fine afterwards. No check engine light.

Steps taken so far:
New spark plugs
Complete cleaning of throttle body
New intake manifold runner control valve
Updated the computer software
Local shop and dealership both ran diagnostics, nothing came up.

Really hoping someone has had this exact issue before and can say I did "this" which fixed it, before I continue throwing money at this problem.

Thanks!
 

·
Registered
Joined
·
205 Posts
Check the crankshaft and camshaft position sensors. They could be intermittent. Also check the map sensor. Problem here is that it leaves no code but your engine will be weak or feel to be weak. Are you mechanically savvy? I fix my own car and do preventive maintenance on my vehicles on a regular basis such as cleaning the air filter every week. And every few thousand miles Checking and cleaning the manifold runner actuator, purge valve inspection and cleaning the vvti solenoid valves.
Change oil and other fluids except cvt. ( I let the dealer do this )
Your fuel pump could be bad too. This car is very easy to maintain and parts are relatively inexpensive compared to Japanese or European cars.
By the way, if your car has 100k plus miles better change the radiator filler neck assy or the upper hose assy. before it leaks and overheat your engine. The parts are outrageously cheap. No reason why you should not do it. Mine went to 234k miles before it crumbled like chalk. I did not realize that this could be a problem. Now I scour the internet for problems that are actually preventable.
 

·
Registered
Joined
·
71 Posts
hey guys just checking in bc my wifes junk dreaded compass which has just started stalling ouit randomly two days ago.

happened for the first time after she coasted to a stop light and was waiting in line and then the oil light came on for a second and the car died. after 2 min she restarted it and drove it straight to the dealer who then drove it around all day and checked for codes and found nothing :mad:

so she gos to work again today and same thing happens only this time no oil light and a few attempts at cranking and it started again. not wanting to get charged 200$ for re flashing and diagnosing again she decided to proceed with caution to work and the car died again!!!!!

it is also jerking and sputtering sometimes during acceleration

125,000 miles right now. currently also has the fuel tank issue which prevents the car from being filled at a fuel pump with pressurized nozzel (fuel comes back out due to blockage or something)

SilverCola, did fixing the purge valve for the EVAP system fix your issue? im wondering of the EVAP system is the cause of both issues on my wifes car right now
 

·
Registered
Joined
·
25 Posts
hey guys just checking in bc my wifes junk dreaded compass which has just started stalling ouit randomly two days ago.

happened for the first time after she coasted to a stop light and was waiting in line and then the oil light came on for a second and the car died. after 2 min she restarted it and drove it straight to the dealer who then drove it around all day and checked for codes and found nothing :mad:

so she gos to work again today and same thing happens only this time no oil light and a few attempts at cranking and it started again. not wanting to get charged 200$ for re flashing and diagnosing again she decided to proceed with caution to work and the car died again!!!!!

it is also jerking and sputtering sometimes during acceleration

125,000 miles right now. currently also has the fuel tank issue which prevents the car from being filled at a fuel pump with pressurized nozzel (fuel comes back out due to blockage or something)

SilverCola, did fixing the purge valve for the EVAP system fix your issue? im wondering of the EVAP system is the cause of both issues on my wifes car right now
Yes it did. It fixed my issue 100%
 

·
Registered
Joined
·
1 Posts
hey guys just checking in bc my wifes junk dreaded compass which has just started stalling ouit randomly two days ago.

happened for the first time after she coasted to a stop light and was waiting in line and then the oil light came on for a second and the car died. after 2 min she restarted it and drove it straight to the dealer who then drove it around all day and checked for codes and found nothing :mad:

so she gos to work again today and same thing happens only this time no oil light and a few attempts at cranking and it started again. not wanting to get charged 200$ for re flashing and diagnosing again she decided to proceed with caution to work and the car died again!!!!!

it is also jerking and sputtering sometimes during acceleration

125,000 miles right now. currently also has the fuel tank issue which prevents the car from being filled at a fuel pump with pressurized nozzel (fuel comes back out due to blockage or something)

SilverCola, did fixing the purge valve for the EVAP system fix your issue? im wondering of the EVAP system is the cause of both issues on my wifes car right now
Yes it did. It fixed my issue 100%
Has anyone else resolved this issue by having the purge valve fixed and/or replaced? I've been experiencing this for the last year and now have the same error code (Incorrect Purge Flow), so I am taking it into the shop on Tuesday. I'd prefer to give him some direction on this rather than asking him to spend a lot of time (and my money) figuring it out on his own, so it would be helpful to know if the sample size is greater than one. Thanks!

P.S. Guinness, I had the jerking/sputtering upon acceleration awhile back, very noticeable when going uphill, and went away after spark plugs were replaced.
 

·
Registered
Joined
·
2 Posts
Jeep Compass Shudders, No power in Acceleration and Dashboard has lights

Can you please tell me for those who had encountered this problem. My jeep compass 2007 recently is giving a problem, the engine shudders and there is no acceleration power while two lights in the dashboard are "ON" (Electronic Throttle and Traction Control). This usually happen when I am at stop lights. I tried to accelerate but nothing happens and engine shudders. Any help please.


Thanks
 
1 - 7 of 7 Posts
Top