My Jeep Compass Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello I am new here and my wife and I own a 2007 Jeep Compass Sport package 4x4. Our warranty ended in June on this vehicle and now it is having trouble starting. We had this issue when it was under warranty but they could not find anything wrong. It is an intermittent issue and there is no rhyme or reason to when it happens if it happens at all. We have had the battery replaced and alternator checked and it is still happening.

Some times when you go to start the Jeep the engine will not make a noise. The only thing that comes on are the lights on the dash and that's it. If we turn the key back to the off position and then back to the crank the same thing will happen a few times in a row then finally it will try and crank and start right up. There is no noise coming from the engine bay. It seems to happen more in the summer time than in the Winter and like I said, it will run great for a few weeks or a month or so then all the sudden you go back out to the vehicle and it will not even try to crank yet all the lights work etc... We have tried both sets of keys that have come with the Jeep and the dealership did replace the "main controller".

Any thoughts would be greatly appreciated.

Thanks,
Spadje
 

·
Registered
Joined
·
315 Posts
Could be a grounding issue, may be time to take a wire brush to some of the grounds. also clean up the battery terminals and the inside of the battery connectors. at least we could rule that out.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Did not check the grounds but the terminals are clean. I installed a new battery about a week ago and cleaned the terminals and it worked great for a week. Then this morning my wife goes out to head to work and it does it again. I will see if I can get to the grounds and check them when we get off work.

Thanks,
Spadje
 

·
Registered
Joined
·
1,897 Posts
Well if its doing it now and you have a record of it being report (on a work order). the dealer will honour it under warranty still since they could not find the problem.
It could be a bad TIPM which are expensive.

Only thing is how you get it there and when you do does it fail for them to observe and test.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5 (Edited)
That is the catch. They had it for 3 days straight and stated they could never get it to fail. They did replace a main controller...not sure what that was but it was about 400 bucks ( we didnt pay anything since it was under warranty ).

EDIT: After doing some research the TIPM is what they replaced.
 

·
Registered
Joined
·
1,897 Posts
Well at least that much is eliminated. I would still contact them since the longer you leave it without them in the loop the less chance of having it covered under a warranty extension, that being because it was reported during warranty and still unresolved.

Even if it is not doing it each time. Let them decide on the next step since you won't pay for it. Keeping quiet too long is a certain receipe for a big bill you could have avoided.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
The grounds look good nothing to see on them. It happened again to my wife when she was leaving the doctors office. It was a very hot / humid day and when I got there it still would not crank ( 20min after the last time she tried ) Everything on the vehicle comes on but the engine will not make a sound. I put the transmission in neutral then back into park and tried to crank and it started right up. I am wondering if it could be a sensor for it to know that it is not in gear when it really is? If it thinks its in gear will it just sit there?

Thanks
Spadje
 

·
Registered
Joined
·
1,897 Posts
Neutral switch is my first suspect from your post. Next time it does it push up further on the shifter as far as you can and see if it does start, don't move it down at all just push up/forward as far as it will go and turn the key. Even if you can't get it by pushing up the dealer can check the proper position of the neutral switch. Otherwise I would have said a dead starter but your shift to N and back to Park ruled that out.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
That is what I was thinking. We are taking it back to the dealership in the morning and I will make sure they make a note of what I did that seemed to resolve it.

After thinking about it I realized it has never done it with me driving....I am wondering if maybe my wife just isn't throwing it into park like I do....

Spadje
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
Well they stated that the position sensors are fine. They are now replacing the Ignition system....
 

·
Registered
Joined
·
1 Posts
2007 compass won't start

I had the same issue that went on for a couple months. It would click and all the dash lights came on. I would keep trying and it finally started. when I went to the shop they checked the system and no issues. One time I got a jump and it started right up. Finally I had a night when it just wouldn't start for a long time. When it finally started it went into what I found out later was a safety mode that would not let the truck go past 30mph. I limped to the dealership had to get system rebooted. What I needed was a new key. My old key had a pc type board in it. The new keys have a real chip. It was explained that the old key chip was malfunctioning and a new key would take care of it. I got a new key with chip and they shaved down the key on the remote fob. now I have my remote and a separate key. its been over a month with no issues. Hope this helps someone else down the road.
 
1 - 11 of 11 Posts
Top