My Jeep Compass Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My friend has a 2007 Compas with the 2.4 liter engine, automatic transmission, and just over 90,000 miles on it. It runs and drives fine, but there is a distinct rattling or knocking sound coming from the passenger side of the engine. It doesn't sound like an internal knocking like a rod knock or something like that. It's coming from around where the pulleys and serpentine belt are on the side of the engine. The sound also comes and goes, getting louder or quieter, or sometimes it goes away altogether. It also seems to have something to do with engine load because when I was looking at it, I had her turn off the AC and it stopped doing it while idling. That's not to say that it's AC related though because she said it comes and goes all the time. Then again, that doesn't mean it's not AC related either. I thought perhaps it could be the belt tensioner rattling against it's stop if the belt has stretched? Or maybe a noisy idler pulley, or loose bracket for something? It's so tight on that side of the engine that I can't get my hand in there to wiggle things to see if anything is loose. Any suggestions on where to look first or if there's a common component that starts rattling on that side of the engine? Thanks!
 

·
Super Moderator
Joined
·
1,851 Posts
Thanks for the update. That's what these auto forums are all about.
 

·
Registered
Joined
·
1 Posts
I have the same issue with my 2014 Compass Limited. I changed idler pulley and noise is still there. Also, after a quarter mile of driving it the battery light comes on. but if I turn off the engine and restart it resets itself for another half mile or so.. anybody have an idea ?
 

·
Registered
Joined
·
2 Posts
I have the same issue with my 2014 Compass Limited. I changed idler pulley and noise is still there. Also, after a quarter mile of driving it the battery light comes on. but if I turn off the engine and restart it resets itself for another half mile or so.. anybody have an idea ?
I have the same problem on my 2011 Compass Limited 2.4 2wd - I have replaced all of the pulleys, replaced the tensioner, replaced the ac compressor, replaced the alternator, replaced the water pump, replaced the power steering pump, replaced the harmonic balancer w/ seal. It's still making the noise. Did anyone ever find a solution to this?
 
1 - 5 of 5 Posts
Top