My Jeep Compass Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2007 Compass that we had jsut been driving. We went to start it after sitting for a half hour and nothing. All dash lights worked, headlights, radio, heater, wipers all came on. The strange thing was that the remote door locks and panic on the key did not work either. I took out several fuses but did not see any that were blown. I tried to start again and it started right up and the remote also worked again.

Does anyone have any ideas what might have caused this???
 

·
Registered
Joined
·
1,897 Posts
Depends on a lot.

How far the start signal got. Did the starter solenoid get activated and if so the contact maybe bad or solenoid failed. But a lot goes on before that. You have to eliminate the obvious. Battery, battery post connections are clean etc.
 

·
Registered
Joined
·
26 Posts
hope it isn't what just happened to mine, I have a 08 that did that, it just stoped starting, lights and everything would work find but the key wouldn't turn the car on.... Got it diagnosed at a dealer this week its going to cost me $1050 dollars, they claim my motors wiring harness is corroded causing the starting issue
 

·
Registered
Joined
·
2 Posts
Will I have the same problem right now, and what I do is hit the battery (-) 5 or 6 times to get the car Electricity back, and if it's not working I use a Jump Starter. However, the real problem is the battery because one of the work in DOBBS told me that.
GOOD luck.
 

·
Registered
Joined
·
1,897 Posts
hope it isn't what just happened to mine, I have a 08 that did that, it just stoped starting, lights and everything would work find but the key wouldn't turn the car on.... Got it diagnosed at a dealer this week its going to cost me $1050 dollars, they claim my motors wiring harness is corroded causing the starting issue
LOL
Run as fast as you can from that dealer. If you replace everything it will work. That appears to be their perspective. Find a good independent shop that has a focus on electrical issues and have then diagnose it.

But for starters, or to start with I should say. Be sure you battery connections are good and the battery is still in good shape. If its the original battery its already at the end of life. In other words if your around 5 years that is the useful life of a battery. especially for winter use. As a repair goes the battery is a cheap fix. But get quality battery paying attention to they warranty. The Walmart EverStart are pretty good as far as mass merchandizer parts go. You should charge it before installing though. But be certain your connections are good at the posts as well.
 

·
Registered
Joined
·
1 Posts
hope it isn't what just happened to mine, I have a 08 that did that, it just stoped starting, lights and everything would work find but the key wouldn't turn the car on.... Got it diagnosed at a dealer this week its going to cost me $1050 dollars, they claim my motors wiring harness is corroded causing the starting issue
Dealing with this exact issue right now. Bought it used a year ago with the inner fender liner missing. Who thinks to check that, did they not check it either? Replaced the main relay, nothing.:(
 

·
Registered
Joined
·
1 Posts
I'm having a very similar issue right now. It only happens after driving for 30+ minutes normally. I've narrowed it down to it would only happen if I was running heat for a while, or this week when i drive for a while with the weather being warm. It seems something is overheating or a sensor is shutting something down because of the heat. So basically I think it has to do with heat and electronics somehow. Also the battery is newish and has never been the issue to my knowledge. Any ideas?
 
1 - 7 of 7 Posts
Top