My Jeep Compass Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
having a real problem with Jeep/Chrysler find a part for my 2007 Compass. I am sure I will find a reference to the exact same issue in past threads. If you can help with specific past or current threads please do...
2007 Jeep Compass 2.4L 4WD
pulled code that identified Crankshaft Position Sensor (no, not camshaft pos sensor). IRF (independant repair facility) ordered replacement from Advance Auto and turned out not a match to my part. Jeep part # 5033307AC. My part has a 90degree bend on the connector so it will clear other stuff. the connector is also 90 degree off from the bracket hole that the bolt goes through. see attachment. Note that the jeepey.com sensor if you care to look it up, is close but not quite a match as this is a UK part? Chrysler engineering/quality told the local Chrysler dealership that some of the 2007 model year used the camshaft position sensor interchangeably (#5033308AB), that is incorrect because when my IRF received that part, it did not fit as the depth was wrong and the connector was in the wrong position to make a connection. It's been two+ weeks.
Attached Thumbnails
 

Attachments

·
Registered
Joined
·
1,897 Posts
For those type of sensors going with the OEM (JEEP) part is historically been the best choice. This is from experiences on the Grand Cherokee forums where many find they're doing the job twice due to bad parts (new). Its a critical sensor and has to work flawlessly.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
2007 crank pos sensor

@DEF1ANT - that IS identical from what I see.
@tripplec - the problem is that Jeep/Chrysler (OEM) have not been able to get me the right part!

that begs the question, "is the crankshaft position sensor and the "speed sensor" the same or located in the same proximity to where my mechanic would have pulled the wrong sensor????????
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
2007 crankshaft position sensor RESOLVED

Thanks to DEF1ANT for finding the pic of the VSS at RockAuto.com!
I sent that photo to my repair shop. And in follow up speaking to the mechanic found that they had pulled the sensor from the transmission. I asked why if the codes said Crankshaft. Turns out that the diagram that the local Chrysler dealer sent them for location of the sensor showed it as being on the tranny? I cannot be sure since I did not see the drawing. I agree that the diagrams I have seen are very ambiguous as far as locations and detail (they should really use photos)!
Anyway, after all that, the original part ordered from advance auto was the correct part and they had just not found the correct location of the crankshaft position sensor! At least it didn't cost me $1k! It did cost me three weeks of trying to find a ride to work! Lesson learned, use the myjeepcompass forum!
 
1 - 5 of 5 Posts
Top