My Jeep Compass Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello,

I have a 2010 Jeep compass sport 4x4. For about the past three weeks I have been having strange problems, almost always right after starting the car, I lose power, have really rough idle, and have the ETC and traction lights on the dash come on.

Mine seems to be more when I first start it after it has been sitting, like over night. However, I noticed that if the ETC/traction lights are on, if I go to the gas station and add fuel to the tank and restart the car it 'fixes' it, usally for the rest of the day (I drive my vehicle for work, sometimes up to 200 miles per day). I tried turning the car off and restarting, but nothing fixes it except putting fuel in. The amount of fuel in the tank doesn't seem to be related to the issue either. The first time it happend, I had 1/4 tank of fuel, but It happens when it's at 1/2 and 3/4 or even on Full also. I have been trying to not fill it at the end of the day so that if the problem occurs when I start up the next day I can drive two blocks from my house in limp mode and add fuel at the gas station.

So far I have cleaned the throttle body, and MAF sensor, changed the air filter, changed the gas cap, put in new spark plugs (and inspected all of the wiring harness' and vacumm lines). None of those things fixed it.

Last week I bought a code reader, and the android Torque pro app. When I run the system check the app tells me that it is unable to test the EVAP system because dependent tests failed, or are unavailable. Non of the codes that I had when the check lights came on said anything about EVAP though, but it appears to be a EVAP failure of some type because adding fuel to my tank somehow fixes the problem. I went ahead and replaced the canister purge valve (25.99 at autozone) just in case, but this did not fix the problem. I inspected the outside of the vapor conister, and the hoses going to it and don't see any problems at a glance. I was also reading that this vehicle has a vapor leak detection pump, which is available to order for around 35 dollars. Does this sound like a possible culprut?

I have read of people having similar problems and fiding that it was a bad intake manifold (it's plastic) but I don't have any codes currently that indicate that, other than engine idle higher and lower than expected codes if I have the scanner hooked up with the dash lights come on.

Anyone had similar problems? any ideas?

Thanks,

Isaiah
 
1 - 1 of 1 Posts
Top