My Jeep Compass Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello everyone,

I have a 2014 2wd 2.0 4cl compass. I got it new in June of 2014. By September 2014 I had 24,000 miles on it (I commute a lot) and the first RR wheel bearing was replaced. Dealership was Criswell Jeep in Gaithersburg MD. Service was fine, no biggie. Jump ahead to may 2015 @ 39,000 miles. Same RR wheel bearing needed replaced. Took it back in, serviced, shop waived the service charge as "goodwill" because apparently the wheel bearing was no longer covered @36,000. Also, I just found out it wasn't actually covered and it was "goodwilled" to me today. Jump to today, at 60,000 miles ... the SAME RR wheel bearing is bad. Now, Criswell is working me over on the issue. This seems so wrong to me considering its the same wheel bearing now 3 times in a row. Im supposed to go in and talk to them in an hour .... any advice or recourse? Thanks in advance.
 

·
Registered
Joined
·
8 Posts
Hello everyone,

I have a 2014 2wd 2.0 4cl compass. I got it new in June of 2014. By September 2014 I had 24,000 miles on it (I commute a lot) and the first RR wheel bearing was replaced. Dealership was Criswell Jeep in Gaithersburg MD. Service was fine, no biggie. Jump ahead to may 2015 @ 39,000 miles. Same RR wheel bearing needed replaced. Took it back in, serviced, shop waived the service charge as "goodwill" because apparently the wheel bearing was no longer covered @36,000. Also, I just found out it wasn't actually covered and it was "goodwilled" to me today. Jump to today, at 60,000 miles ... the SAME RR wheel bearing is bad. Now, Criswell is working me over on the issue. This seems so wrong to me considering its the same wheel bearing now 3 times in a row. Im supposed to go in and talk to them in an hour .... any advice or recourse? Thanks in advance.
my two guesses are a poor quality part and/or i'd tke it to a different shop. I'm intrigued to know what happened with your revisit.
 

·
Registered
Joined
·
409 Posts
Hello everyone,

I have a 2014 2wd 2.0 4cl compass. I got it new in June of 2014. By September 2014 I had 24,000 miles on it (I commute a lot) and the first RR wheel bearing was replaced. Dealership was Criswell Jeep in Gaithersburg MD. Service was fine, no biggie. Jump ahead to may 2015 @ 39,000 miles. Same RR wheel bearing needed replaced. Took it back in, serviced, shop waived the service charge as "goodwill" because apparently the wheel bearing was no longer covered @36,000. Also, I just found out it wasn't actually covered and it was "goodwilled" to me today. Jump to today, at 60,000 miles ... the SAME RR wheel bearing is bad. Now, Criswell is working me over on the issue. This seems so wrong to me considering its the same wheel bearing now 3 times in a row. Im supposed to go in and talk to them in an hour .... any advice or recourse? Thanks in advance.
Hey Otb,

I am sorry to hear about your recent experience with your Compass. Please keep the forum updated on what happens with the dealership. If you have further questions please reach out, via, private message.
 

·
Registered
Joined
·
1,897 Posts
Hello everyone,

I have a 2014 2wd 2.0 4cl compass. I got it new in June of 2014. By September 2014 I had 24,000 miles on it (I commute a lot) and the first RR wheel bearing was replaced. Dealership was Criswell Jeep in Gaithersburg MD. Service was fine, no biggie. Jump ahead to may 2015 @ 39,000 miles. Same RR wheel bearing needed replaced. Took it back in, serviced, shop waived the service charge as "goodwill" because apparently the wheel bearing was no longer covered @36,000. Also, I just found out it wasn't actually covered and it was "goodwilled" to me today. Jump to today, at 60,000 miles ... the SAME RR wheel bearing is bad. Now, Criswell is working me over on the issue. This seems so wrong to me considering its the same wheel bearing now 3 times in a row. Im supposed to go in and talk to them in an hour .... any advice or recourse? Thanks in advance.
I haven't been into the bearing on mine as of yet. Thankfully
I would have said poor parts quality or batch but 3 is pushing it a lot for me to believe that. I am leaning on the bearing is being damaged on installation and can't think what else it might be. Your part bearing will be of entirely different batch than what is using upon original assembly. Seeing the faulty bearing may reveal what is failing within.

Rare to fail anyway even at very high millage vehicles.

I have 3 CVT output shaft seals go now. A slight leak on the short shaft which I noticed doing my oil changes. They are very fragile as it started with my last A-arm change which I had to have dealer install when the shaft pulled out trying to align the mounting bushings. I lost some fluid before getting it reinserted. Had it towed and fixed up. But the seal started leaking afterwards. Some aspects of these are good but others not so much especially when the job needs doing more than once with parts failing.
 
1 - 4 of 4 Posts
Top