My Jeep Compass Forum banner

1 - 8 of 8 Posts

Registered
Joined
3 Posts
Discussion Starter #1
So my 2017 Compass stalled out the other day at a stop sign. I've got that stupid Start/Stop engine thing going and outside of it being annoying, I haven't found one benefit to it. Needless to say after I restarted the vehicle I was treated to a message prompting me to service the engine. Since the vehicle was all of 6 weeks old, I contacted my dealer and brought the vehicle down after a few hours. They had it for about an hour and number of software updates was pretty extensive. Needless to say it drives a whole lot better. It initially felt like I was floating on the road especially versus the 2014 Cherokee I replaced it with. Now it does a much better job of gripping it. Needless to say, I urge you all to stop by your dealership and get the latest updates and I'm done with that whole Start/Stop engine option. Only downside is you have to disable it every time you start the vehicle up.
 

Registered
Joined
87 Posts
Agree on the auto stop/start feature maybe should be something you should be able to turn on IF you want to use it, and not the default setting. Thankfully, it's not available w/manual transmission (even though I have the botton). It's crazy how much cars are dependent on computers & software upgrades nowadays! 馃憥
 

Registered
Joined
156 Posts
Agree on the auto stop/start feature maybe should be something you should be able to turn on IF you want to use it, and not the default setting. Thankfully, it's not available w/manual transmission (even though I have the botton). It's crazy how much cars are dependent on computers & software upgrades nowadays! 馃憥
I bet you that if it wasn't for the fact this helped them get better mileage on paper, then just maybe it would have functioned as an optional item. Down the road as they find more ways to get better mileage, what we want out of start/stop might just happen.
 

Registered
Joined
34 Posts
My wife just had a similar issue this morning.

She took our brand new '17 Trailhawk to work - first time she drove it. I warned her about "start stop" but she claimed she got it. She calls me at the first stop sign and says when it shut down it wouldn't come back on. She says the "D" on the dash info screen turned red and started blinking and the parking break automatically turned on. She put it "P" and pushed the starter button and it came back on and drove as normal. No check engine lights or anything (that she's aware of).

I'm going to drive it around a bit when she gets back from work to see if it does it to me. I'm suspicious it might be user error with her unfamiliarity with the start stop system, but your post makes me concerned there's a glitch.
 

Registered
Joined
156 Posts
My wife just had a similar issue this morning.

She took our brand new '17 Trailhawk to work - first time she drove it. I warned her about "start stop" but she claimed she got it. She calls me at the first stop sign and says when it shut down it wouldn't come back on. She says the "D" on the dash info screen turned red and started blinking and the parking break automatically turned on. She put it "P" and pushed the starter button and it came back on and drove as normal. No check engine lights or anything (that she's aware of).

I'm going to drive it around a bit when she gets back from work to see if it does it to me. I'm suspicious it might be user error with her unfamiliarity with the start stop system, but your post makes me concerned there's a glitch.
It might be time to have the dealer look at it and today being friday, it might be a bit slow for them, along with the weekend. Great time for them to look at it and even book you in the service bay.
 

Registered
Joined
403 Posts
My wife just had a similar issue this morning.

She took our brand new '17 Trailhawk to work - first time she drove it. I warned her about "start stop" but she claimed she got it. She calls me at the first stop sign and says when it shut down it wouldn't come back on. She says the "D" on the dash info screen turned red and started blinking and the parking break automatically turned on. She put it "P" and pushed the starter button and it came back on and drove as normal. No check engine lights or anything (that she's aware of).

I'm going to drive it around a bit when she gets back from work to see if it does it to me. I'm suspicious it might be user error with her unfamiliarity with the start stop system, but your post makes me concerned there's a glitch.
Hi NorthCoastie19,

Please feel free to let us know if you decide to use your Jeep dealership for any further diagnosis. We're happy to reach out on your behalf!

Kori
Jeep Social Care Specialist
 

Registered
Joined
41 Posts
My husband forgot to turn off the auto-off "feature" when he left work one day last week, and was trying to exit his parking lot when, of course, the engine shut off, as it's designed to - except he had drained his battery forgetting to turn off his parking lights when he got to work that day - so there was enough juice to start the car one time, ONE TIME - so when it shut off - it DIED!

He could not restart it because the battery was dead, and he was stuck in the middle of everybody trying to leave his workplace! He had to get jumped. Needless to say he was pretty pissed. You would think the engineers would have been smart enough to disable the engine shut off function if the battery has a low charge :( It was a very embarrassing situation - and thankfully it didn't happen while he was in the middle of the street in an intersection or something - that could have been dangerous!
 

Registered
Joined
34 Posts
So I took ours to the dealership and they found nothing wrong with it... it hasn't happened again, so I guess we will see, maybe my wife just misinterpreted what happened when start stop shut it down.
 
1 - 8 of 8 Posts
Top