My Jeep Compass Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 · (Edited)
The Jeep was working ok, then been sitting for 4 days, and then last week i hit remote ignition on the key fob and started fine for 10 seconds and turned off, with a message on screen "REMOTE START DISABLED START VEHICLE TO RESET". But trying to start the vehicle manually hitting the brakes and the push button did not worked and the message faded away after a while.

Removed the battery for 20 minutes to see if that reset the jeep and now when i open the door the vehicle only shows the mileage and then fades away, no ignition when i press the push button and no engine on when i press on the brakes+push. Both Batteries where checked and are fine and all fuses are also good.

Tow the jeep to the mechanic who has not been able to turn it on yet, but says the problem might be in the RADIO FREQUENCY HUB MODULE, but we have not been able to find that part on the jeep, from the diagram below.

The vehicle honks, locks, unlocks from the fob and the controls on the doors, front lights turn on after i open the door. But no ignition.
Im currently in Nicaragua so no Dealer here, the Jeep was imported.

Any help here will be appreciated, thanks.

13766

13768
 

·
Registered
Joined
·
6 Posts
I have had to jump my jeep EVERY time i want to start it for the past 6 months. 3-6 times a day with a jumper battery.
I have yet to find an aftermarket AUX battery that fits. OEM Aux Bat is crap. Plus the charging systems fries the battery.
 
1 - 2 of 2 Posts
Top