My Jeep Compass Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2018 Jeep Compass Sport. Auto Stop/Start has been causing car to turn off on its own when feature engages at a stop sign or red light. Once off car will not turn over on first try. Usually the second or third try it will turn over. The auto stop/start light will turn on at times on dash and then turn off. Also had the following service messages appear then go away after driving for a couple of miles.
Service ESC System
Service Hill Holder
Dynamic Steering torque service required
Also noticed batttery voltage going from 14.4 or 14.5 down to the 12s when in park or at stop sign or red light. Anyone one else have this issue and if so what was the fix? Dropped the car off at the dealer to see what they say. Car has 57k miles.
 

·
Registered
Joined
·
1 Posts
I have a 2018 Jeep Compass Sport. Auto Stop/Start has been causing car to turn off on its own when feature engages at a stop sign or red light. Once off car will not turn over on first try. Usually the second or third try it will turn over. The auto stop/start light will turn on at times on dash and then turn off. Also had the following service messages appear then go away after driving for a couple of miles.
Service ESC System
Service Hill Holder
Dynamic Steering torque service required
Also noticed batttery voltage going from 14.4 or 14.5 down to the 12s when in park or at stop sign or red light. Anyone one else have this issue and if so what was the fix? Dropped the car off at the dealer to see what they say. Car has 57k miles.


I too have a 2018 Jeep Compass Trailhawk with 42K and my truck has also presented itself with the same issue. The Dealership mentioned I have to take it in.
 

·
Registered
Joined
·
2 Posts
I have a 2018 Jeep Compass Sport. Auto Stop/Start has been causing car to turn off on its own when feature engages at a stop sign or red light. Once off car will not turn over on first try. Usually the second or third try it will turn over. The auto stop/start light will turn on at times on dash and then turn off. Also had the following service messages appear then go away after driving for a couple of miles.
Service ESC System
Service Hill Holder
Dynamic Steering torque service required
Also noticed batttery voltage going from 14.4 or 14.5 down to the 12s when in park or at stop sign or red light. Anyone one else have this issue and if so what was the fix? Dropped the car off at the dealer to see what they say. Car has 57k miles.
I too have a 2018 Jeep Compass Trailhawk with 42K and my truck has also presented itself with the same issue. The Dealership mentioned I have to take it in.
SAME EXACT THING IS HAPPENING TO MINE! Did you figure out what it was? I don’t have warranty on my car anymore so the dealership couldn’t tell me.
 

·
Registered
Joined
·
2 Posts
I have a 2018 Jeep Compass Sport. Auto Stop/Start has been causing car to turn off on its own when feature engages at a stop sign or red light. Once off car will not turn over on first try. Usually the second or third try it will turn over. The auto stop/start light will turn on at times on dash and then turn off. Also had the following service messages appear then go away after driving for a couple of miles.
Service ESC System
Service Hill Holder
Dynamic Steering torque service required
Also noticed batttery voltage going from 14.4 or 14.5 down to the 12s when in park or at stop sign or red light. Anyone one else have this issue and if so what was the fix? Dropped the car off at the dealer to see what they say. Car has 57k miles.
SAME EXACT THING IS HAPPENING TO MINE! Did you figure out what it was? I don’t have warranty on my car anymore so the dealership couldn’t tell me.
 

·
Registered
Joined
·
1 Posts
SAME EXACT THING IS HAPPENING TO MINE! Did you figure out what it was? I don’t have warranty on my car anymore so the dealership couldn’t tell me.
Just started for me today. 2018 Compass Trailhawk. 43400 miles. Startup it flutters gauges, cranks for less than a second, then nope. Says "Service ECS System" and "4WD NOT AVAILABLE". I sat for nearly 2 hrs, tried jumpstarter pack, nope. Tried V8 Dodge ram jump start, nope. I pressed FOB against right side where push-to-start button is and it fired up.

Could be a low fob battery apparently..... Could be low oil. (I'm due for a change)... Taking it in next week. This is insane because its NOT the battery that's causing this. Try to put your Fob next to column. I have a video I can link you to of that temporarily solving my issue.
 
1 - 5 of 5 Posts
Top