My Jeep Compass Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello everyone , my compass has been acting weird lately . Sometimes I have to work out of town and I leave my car at the office and take the company van . I left my car sitting for 2 weeks and came back and drove it for like 4 days with no problems . Then I left it at the office for 2 days and it wouldn’t start . I’ve jumped it and drove it 2 hours home and 2 hours back to work again the next morning but after work it was dead again . I took the main battery out and took it to autozone and they said it’s 100% charged and a good battery still . I put the battery back and my car started right up and drove home . Next morning it was dead again . And that’s where I’ve left it for two weeks because I’ve been busy with work . I can’t use my alarm anymore to unlock so I take the little key out of the fob to open to doors . When I try to start it , the needles on the gauges just jump a little . That’s all . Any idea what could be going on ?

Also I don’t know if it’s related but my radio which is the big u connect sometimes gets lines all thru the screen like it’s broken . Then goes away on its own . And the automatic start and stop has never worked. And my rear view camera works like 25% of the time . And I’ve noticed my remote start has stopped working a few weeks ago . Thanks for any help !!
 

·
Registered
Joined
·
398 Posts
Hello everyone , my compass has been acting weird lately . Sometimes I have to work out of town and I leave my car at the office and take the company van . I left my car sitting for 2 weeks and came back and drove it for like 4 days with no problems . Then I left it at the office for 2 days and it wouldn’t start . I’ve jumped it and drove it 2 hours home and 2 hours back to work again the next morning but after work it was dead again . I took the main battery out and took it to autozone and they said it’s 100% charged and a good battery still . I put the battery back and my car started right up and drove home . Next morning it was dead again . And that’s where I’ve left it for two weeks because I’ve been busy with work . I can’t use my alarm anymore to unlock so I take the little key out of the fob to open to doors . When I try to start it , the needles on the gauges just jump a little . That’s all . Any idea what could be going on ?

Also I don’t know if it’s related but my radio which is the big u connect sometimes gets lines all thru the screen like it’s broken . Then goes away on its own . And the automatic start and stop has never worked. And my rear view camera works like 25% of the time . And I’ve noticed my remote start has stopped working a few weeks ago . Thanks for any help !!
Sound like an electrical issue. Make sure both battery terminals are attached properly (there are two batteries in the car, check both). If they look fine, I would take it to the dealer.
 

·
Registered
Joined
·
13 Posts
Sounds serious for a 2018 model, I'd take it back to the dealership it came from!

As Tripod suggests, check the battery is good and tight, when I bought my Jeep (a 2011) I found it was a bit slow starting when I went to buy it, I just assumed it had been sat for a few weeks and the battery was low. I got home and stalled it trying to reverse on to my drive, went to restart and the whole thing was dead, even though I'd just drive 100 miles!

Turns out the battery terminals were just a little loose. I nipped them up and its been good as gold for the past 6 months.
 
1 - 3 of 3 Posts
Top