My Jeep Compass Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Hello everyone! I'm new here and new to the jeep family. I purchased my very first jeep a few weeks ago. After renting Compasses and Cherokees a few times when we were out of state, we fell in love with them and decided to purchase a slightly used 2019 Compass Limited as my new daily driver. I have been absolutely loving the car (except for the part where the windshield shattered the first week we owned it due to the wiper slamming down- and they're on a 6 week backorder :oops:)

However, it has acted up a few times already. Three times now, when I've gotten in, it thinks the vehicle is already on- or it just doesn't start. It doesn't even try to turn over. the radio may or may not still be playing. we try to turn it on, then off, but it literally does nothing. Eventually, it actually powers down, and then it starts as normal.

I've never owned a vehicle newer than a 2004- in fact my other vehicle is a bare bones package 2004 Dodge Ram 2500- so all these new bells and whistles are new (and already aggravating) to me :LOL:
Could this be the software update I've read about? any other suggestions?

Thanks everyone!
 

·
Moderator
Joined
·
962 Posts
Welcome!

You probably just discovered why the last owner traded it. Electronics are neat when they work, but IMHO they don't belong on a Jeep of any variety. Too sensitive. Jeeps have to be rugged and durable. An undependable Jeep is a travesty.

As for your problem. I've had two 2nd Gen Compasses and neither had your problem. However, I had a Saturn with a similar problem and it was traced to the security system. If it wouldn't start I had to wait 10 minutes to try again. This might have to be repeated, so late for work. :( My solution was to keep it locked whenever I left it, not for security reasons, but for security system reasons. I kept it locked even if it was safe in my garage. For some weird reason it liked being unlocked in the morning and it would start fine every time. If I left it unlocked I'd have the problem: all I could do was lock it and wait 10 minutes, then unlock it, get in and turn the key. Now mind you that was a Saturn not a Jeep, but its worth a try.

Good luck and please report back.

Any chance you got a warranty with it? Maybe the dealer will trouble shoot it. On the other hand if my suggestion works, maybe you're better off not letting them monkey with it. From what I've seen on here and other forums, dealers across the board -- Jeep and others -- are pretty helpless when it comes to electronic gremlins.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Welcome!

You probably just discovered why the last owner traded it. Electronics are neat when they work, but IMHO they don't belong on a Jeep of any variety. Too sensitive. Jeeps have to be rugged and durable. An undependable Jeep is a travesty.

As for your problem. I've had two 2nd Gen Compasses and neither had your problem. However, I had a Saturn with a similar problem and it was traced to the security system. If it wouldn't start I had to wait 10 minutes to try again. This might have to be repeated, so late for work. :( My solution was to keep it locked whenever I left it, not for security reasons, but for security system reasons. I kept it locked even if it was safe in my garage. For some weird reason it liked being unlocked in the morning and it would start fine every time. If I left it unlocked I'd have the problem: all I could do was lock it and wait 10 minutes, then unlock it, get in and turn the key. Now mind you that was a Saturn not a Jeep, but its worth a try.

Good luck and please report back.

Any chance you got a warranty with it? Maybe the dealer will trouble shoot it. On the other hand if my suggestion works, maybe you're better off not letting them monkey with it. From what I've seen on here and other forums, dealers across the board -- Jeep and others -- are pretty helpless when it comes to electronic gremlins.
It does still have some of the original factory warranty left, but no extended warranty as it wasn't CPO. My boyfriend actually just called a local dealership who told us to bring it down and check for software updates. I have noticed that two of the times its happened, it had been unlocked, so I think you're on to something there. I'll definitely report back! I'm hoping it's just something minor like that and not a persisting issue. :)
 

·
Registered
Joined
·
34 Posts
It does still have some of the original factory warranty left, but no extended warranty as it wasn't CPO. My boyfriend actually just called a local dealership who told us to bring it down and check for software updates. I have noticed that two of the times its happened, it had been unlocked, so I think you're on to something there. I'll definitely report back! I'm hoping it's just something minor like that and not a persisting issue. :)
Please check the oil level in the engine.
 

·
Registered
Joined
·
10 Posts
Hello everyone! I'm new here and new to the jeep family. I purchased my very first jeep a few weeks ago. After renting Compasses and Cherokees a few times when we were out of state, we fell in love with them and decided to purchase a slightly used 2019 Compass Limited as my new daily driver. I have been absolutely loving the car (except for the part where the windshield shattered the first week we owned it due to the wiper slamming down- and they're on a 6 week backorder :oops:)

However, it has acted up a few times already. Three times now, when I've gotten in, it thinks the vehicle is already on- or it just doesn't start. It doesn't even try to turn over. the radio may or may not still be playing. we try to turn it on, then off, but it literally does nothing. Eventually, it actually powers down, and then it starts as normal.

I've never owned a vehicle newer than a 2004- in fact my other vehicle is a bare bones package 2004 Dodge Ram 2500- so all these new bells and whistles are new (and already aggravating) to me :LOL:
Could this be the software update I've read about? any other suggestions?

Thanks everyone!
Get the software update. I had a similar issue. It would stall and then be impossible to restart just like you described. Update fixed it. The dealer was reluctant to install it which i still don't understand, but i insisted. Now no more problem
 
1 - 6 of 6 Posts
Top