My Jeep Compass Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Just picked up a new compass and halfway home the screen starting going crazy jumping around from climate to radio to rear view camera,etc.. A random phone call was made and heat went on and then off. Any idea what could cause this other than a defective unit. I was using Car Play while all of this happened. Thanks for any help!!!
 

·
Registered
2021 Jeep Compass Trailhawk
Joined
·
461 Posts
Welcome. Take it back. I think that when it comes to this tech many old dealers have no clue how to set this stuff up.
 

·
Administrator
Joined
·
2,055 Posts
Welcome! I have no idea what Car Play is, but I agree with BooMan: you're under warranty so let the dealer cope with it.
 

·
Registered
2021 Jeep Compass Trailhawk
Joined
·
461 Posts
My kids understand it better but it allows you to use your phone on the Uconnect screen. It is nice for using Waze.
 

·
Administrator
Joined
·
2,055 Posts
Waze? I'm from the old school of points and condensers. Fancy cars had AM radios. Only Cadillacs had a/c.
 

·
Administrator
2019 Jeep Compass Latitude
Joined
·
330 Posts

·
Registered
Joined
·
48 Posts
Mine did exactly the same the day I collected it, sadly in the UK I’ve been told it could take up to 6 months to obtain a new unit complete plus the trim (allegedly the trim snaps once they try and remove it) I’m returning my Jeep to the dealer but won’t be replacing it for another Jeep.
Look closely at the screen, you will notice bubbles or delimitation, mine jumps about even more when it’s warm after a few miles.
 

·
Registered
2022 Jeep Compass TH
Joined
·
5 Posts
Just picked up a new compass and halfway home the screen starting going crazy jumping around from climate to radio to rear view camera,etc.. A random phone call was made and heat went on and then off. Any idea what could cause this other than a defective unit. I was using Car Play while all of this happened. Thanks for any help!!!
Just out of curiousity, do you live in a cold climate area? My Uconnect worked well for my first few weeks, then as the temp dropped a bit more (sustained under 20 degrees F) the screen almost seemed like it was too cold to work properly. It was doing things as you described, as the car and screen unit area warmed up, I didn't notice it as much. Im looking forward to their first software update...hopefully it comes sooner than later...I assumed it would be buggy being the first version on a new connect system, but, it does suck to have a new car and things not work as intended. I guess that's the chance you take when buying a brand new car with a brand new infotainment system.
 
1 - 12 of 12 Posts
Top