My Jeep Compass Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Hey guys! In October I traded in my 2014 Patriot for a 2018 Compass Latitude with 6400mi. I loved my Patriot (Sport with primitive features) but now to this Compass with a sunroof, preferred package, and more computer stuff - which sounds good on paper but I've more issues in three months than I had with the Patriot in three years. Does anyone have an issue with the 5.0 Uconnect shutting off? Message on the dash says "sound system unavailable". Its not even the fancy radio with XM/Nav, etc. It just started in the past few days. However, since I've had it, the shifter lights work intermittently and the passenger front speaker kicks on to full volume like 10 minutes into the drive.
Are all these related somehow? Its always wet in NE Ohio so I just assumed thats what's messing with the shifter? I'll handle it under warranty, but I just wanted to get some feedback.
Thanks!!
-Diane
 

·
Registered
Joined
·
23 Posts
I got my 2018 Compass Sport last October. It also has the 5.0 Uconnect. Starting in about February of this year I've had issues with the Uconnect shutting down and rebooting. Happens more regularly when I listening to my phone through the system, but has on occasion happened when it's just the radio playing. I haven't noticed any other problems with speakers or shifter light (MT). Also, I've noticed over the past 6 months or more that my USB buttons appear to be greyed out. The front one still charges my phone when plugged in, but doesn't light up when it used to before. I've never used the one in back.

I'm not overly frustrated with it, and will have them check things out on my next oil change. I'm almost positive they're going to tell me "that's how it is supposed to be", even though its not.

~meh~
 
1 - 2 of 2 Posts
Top