My Jeep Compass Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello to all. I'm new here on this forum... I've had my '09 Compass since July, and I began switching out the stock head unit for one I had in my old car.

I see that I can't post pictures yet, since it hasn't been two weeks, but I'll detail what I've done so far. When I'm able to post pictures, I'll put some up.

For starters, my vehicle did not come with the Boston Acoustics setup... so I wasn't happy with it. So I am swapping out the OEM head unit with a Kenwood KDC-MP635 head unit. I have a Kenwood KHD-C 710 Music Keg with a 120 GB hard drive, and I'm running all the sounds through a 6-channel JL Audio amplifier, and I'm also adding a 12" JL Audio subwoofer. For now, I'm keeping the stock speakers. Eventually, I'll change them out.

My biggest issue was finding a way to run the 4-gauge power cable from the battery into the car. I just could not find a grommet in the firewall or anything like that. As a matter of fact, that's how I ended up finding this forum, trying to see if someone else figured it out. I read on another forum (I think it was the Jeep Commander forum) that there is a grommet just behind the driver door, and it was possible to run the power cable inside the left fender. I checked my vehicle, and there was the cabling and the grommet. I immediately removed the driver door, ran the cable, made a hole in the grommet, and got the cable in the car. After that, getting the cable to the back where I have the amplifier was easy; all the panels just pop out with a tug.

I found with some research that the wire harness that is needed for this vehicle has to have the Serial Bus box, since the power coming to the OEM head unit comes from the computer. To make the install clean, I'm running the speaker wires out of the amp into the wire harness, to make use of the original speaker cabling.

I ran the rest of the cables on the other side of the car (to avoid the hum caused by power interference). Once I got the cables to the front, I removed the glove box and ran the cables behind it. I took a break from the work for the day (I've been at it since 6 this morning); I'll get back to it tomorrow. At this point, I only have to make all the connections in the amplifier, plug in the harness into my head unit, and test for sound.
 

·
Premium Member
Joined
·
1,362 Posts
Welcome to the forum TobyDee, glad to have ya'. Nice writeup on the stereo swap! Get a few more posts in and you can post pics to illustrate which could prove very helpful to our other members! Again, welcome and I hope you enjoy the site! :)

- Cherokee
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Done!

I'm done with the install. Everything works fine.

What I'll do is take pictures of everything (since I know how to take everything apart easily), and when I can post pictures, I'll give a step by step account of what I did. I hope to make things a little easier for others who want to do what I did. A lot of what I did was trial and error; I don't want anyone else running into the same issues. At the same time, I will available to answer all questions.

Thanks to Cherokee for the welcome!
 

·
Registered
Joined
·
169 Posts
How did you eventually get the power from the battery to your sub-woofer? I had trouble finding a hole in the fire wall and didnt see much in the way of holes in the doors, so I just cannabalized the power and heated seats wiring harness (because I dont have either of thsoe options), used a volt meter and found everything I needed including a ground I believe.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Lunch Box, here's what I did:

Like I said earlier, I saw somewhere that there are a bunch of wires run in the left fender. I inspected and found the wires, coming from the front of the car. I couldn't see where the wires went, because when you open the door and look just behind the hinge, there's some kind of material (it may be foam) there. I took a chance and removed the door, and pushed the foam out of the way, and found where the bunch of wires went... into a grommet. If you remove the kick panel on the driver's side and look under the dash, you will see that same bunch of wires. So, I ran my 4 AWG wire from the battery, through the inside of the fender, punched a hole in the grommet, and ran the wire through the hole I punched.
 

·
Registered
Joined
·
169 Posts
Hmph, nice find. I'll have to remember that.
 
1 - 6 of 6 Posts
Top