My Jeep Compass Forum banner

201 - 220 of 261 Posts

·
Registered
Joined
·
240 Posts
I ordered the 2 zone control panel and installed in my Sport and got everything working. I did have to change a couple settings in the BCM but can't recall off the top of my head which those were. If you have any trouble, let me know and I'll pull my config and let you know exactly what I changed.
Sounds good! Can you just pull it just so have I good idea. Rather not be messing about for hours doing this since I already did once...
 

·
Registered
Joined
·
240 Posts
One helpful thing that I've learned while using this software in having a Chromebook that has Bluetooth capability. is that seeing the menu in all the options is much easier on a laptop that can use Android apps. Then it is trying to use my phone.
 
  • Like
Reactions: arudlang

·
Registered
Joined
·
1,028 Posts
Compass2ndgenguy said:
One helpful thing that I've learned while using this software in having a Chromebook that has Bluetooth capability. is that seeing the menu in all the options is much easier on a laptop that can use Android apps. Then it is trying to use my phone.
That is a good idea I never thought of looking for a chromebook, I bought a cheap android tablet and it was slightly better than my phone but not a lot, and its still kind of a pain to export the logs and configuration on the tablet, a chromebook would probably make that a little easier too. Now I have another tech toy to shop for grin:
 

·
Registered
Joined
·
240 Posts
7" is coming in the mail and also got 2 zone HVAC controls to swap out as well so I do not lose my volume and also can use buttons for the climate.

Will update everyone on how it goes with new HVAC controls. If it works, people upgrading should look into it, the part was $50 from a parts yard. <img src="http://www.myjeepcompass.com/forums/images/smilies/icon_smile.gif" border="0" alt="" title="" class="inlineimg" />

K
I ordered the 2 zone control panel and installed in my Sport and got everything working. I did have to change a couple settings in the BCM but can't recall off the top of my head which those were. If you have any trouble, let me know and I'll pull my config and let you know exactly what I changed.
Need your help bro, pm what you did to get this to work.

K
 

·
Registered
Joined
·
240 Posts
Has anyone experienced the dreaded ABS failed like 10-20 times proxy alignment? I finally got it to proxy align after a very long time and many times. Have we figured out why it does this some times? I have never changed anything with ABS, so why would that ever fail...

I won't be tinkering with any more settings till I get my 7" cluster back with correct milage to swap because of this hair ripping issue.

K
 

·
Registered
Joined
·
185 Posts
Discussion Starter #206
Not that I have seen. The only times I've had issues with ABS warning is if my proxy alignment doesn't complete and the modules were out of sync. I think I have manually cleared ABS codes between failed proxy configs. Not sure if it was necessary though.
 

·
Registered
Joined
·
3 Posts
So, I tried to configure Turbo Boost display ando chose IPC.
It spoiled all configs. And had to perform a Proxy Alignment. Transmission, Air Bags, ABS etc, all lit on.

Does any one know how to perform it correctly?
 

·
Registered
Joined
·
240 Posts
So, I tried to configure Turbo Boost display ando chose IPC.
It spoiled all configs. And had to perform a Proxy Alignment. Transmission, Air Bags, ABS etc, all lit on.

Does anyone know how to perform it correctly?
Since compasses were not designed with turbo boost in mind, I am sure that setting is outside the ECU parameters. If this is the case it will not sync and then you will end up with what you have. Change the setting back and keep trying to proxy align until all process is successful.

Endnote is that I have a hard time aligning mine now and last time it took over 15 times of proxy alignment till it worked. So I am not messing with mine anymore till my 7" cluster screen comes back.

K
 
  • Like
Reactions: arudlang

·
Registered
Joined
·
1,028 Posts
Compass2ndgenguy said:
Since compasses were not designed with turbo boost in mind, I am sure that setting is outside the ECU parameters. If this is the case it will not sync and then you will end up with what you have. Change the setting back and keep trying to proxy align until all process is successful.

Endnote is that I have a hard time aligning mine now and last time it took over 15 times of proxy alignment till it worked. So I am not messing with mine anymore till my 7" cluster screen comes back.
Good post. You really should not try to set any option that is obviously and blatantly inapplicable to your car.

The alignments are a pain, although mine do not take anywhere near 15 tries. Still, once I fought everything to the way I wanted I quit messing with it. When these cars are 8-10 years old and they are not somebody's brand new daily driver under warranty will be a good time for people to take bigger risks with the configurations and part-interchange mods.
 

·
Registered
Joined
·
12 Posts
Well, finally got my cables and my obdlink mx and the paid version of the app all together and did some playing around. OOFTDA, that is some tedious work, messing with this crap!

It can take upwards of a half an hour to experiment with one option, since most of them don't work and have to be changed back, and the proxy alignment is a two cable dance that takes minutes on end.

A lot of people praise the app but from my point of view its extremely rough around the edges and tricky to use. Managed to bugger up my car pretty good, got it back to normal I think. Tried several settings and options, most did not work. Travel link did not work on my radio (UAM, I think is the one I have). Enabling apps created an icon for apps but it doesn't do anything. Enabling the oil information option doesn't do anything. Enabling the automatic trip B reset menu doesn't do anything. Took forever to try these and then put things back to stock. Corrupted the vram in the uconnect during the process, that was pretty freaky but it seemed to come out of it after a beer break. Apps icon won't go away even though I changed that setting back and did about a dozen proxy alignments since.

It feels like prospecting in a stream for gold nuggets. Tons of work. High risk. Little reward so far. I have found SOME reward though, so here comes the good news:

DISABLING THE ESS / START STOP SYSTEM DOES WORK! WOOOHOOOOO!!!

And, even though I never really gave a rip about this issue, you can turn down the reverse camera brightness as well. I set mine to about 20%, seems much better at night and much less washed out and no longer over-saturated during the day. Some of you may remember we had a bunch of members all up in arms about the reverse screen brightness about a year ago, went on for a long time before they ran out of temper tantrum fuel. Well, if any of those folks are still here, we have a solution!

These are literally the only two good things I have found so far. Mind you, not counting discounts or credits this has taken around $150 worth of hardware and software and hours of tinkering. I think I could still justify that just to kill ESS alone, personally, but I hope to wring more out of it. I have not yet tried disabling the seat belt reminder module but it shows up as an option, I would love to get rid of that, and neuter the alarm system as well.

When I have time I will try to put together some videos documenting the complete process for ESS and the backup camera. It is in my opinion a pretty tricky sequence for the average consumer and as others have said you better have a lot of free time and no where you need to be when you start messing with it. Battery charger or frequent spins around the block are necessary to keep from killing the battery. I am learning a lot though.
I was able to disable the seat belt chime. But I need help disabling ESS. Can you advise which settings you changed? I had to actually bring my car to the dealer because every single idiot light came on and the Compass was shifting from R to D extremely hard and then in a sort of limp mode. Thanks in advance!
 

·
Registered
Joined
·
12 Posts
Ok so far I was able to successfully turn off the seat belt chime. It also fo3snt even flash in the dash anymore. I also turned off the start stop ESS. I want to enable global window down for sure. Anyone else do any other mods like this?
 

·
Registered
Joined
·
25 Posts
hi there,

Does anybody tried to calibrate the Power Liftgate fully open position thru AlfaOBD, it seems there is a selection on that way in the program.
In my example, I need to limit the opening 3 inches less in order not to hit the ceiling wall once opened.
13493
 

·
Registered
Joined
·
1,028 Posts
Christato71 said:
Would it be possible to upgrade to the 7" display cluster with AlfaOBD
Yes. Would it be possible for you to use the search next time? 🙃

I'm not even sure you need AlfaOBD to swap the radio, I'd have to use the search too to be certain 😁
 

·
Registered
Joined
·
76 Posts
Would it be possible to upgrade to the 7" display cluster with AlfaOBD
you can indeed. I did it my self. The only problem you would have is that alfaobd won't let you write on the cluster odometer. And you would have to find someone to do it with some kind of aftermarket tool for altering the milleage on clusters....

write old cluster mileage if you care about it.
disconnect battery terminal cables (negative probably) on both batteries
remove old cluster.
connect new cluster.
assembly everything together.
coonect batteries terminal cables.

ALFAOBD part

body computer on car configuration change it to TFT Color Display
then proceed to do an proxy alignment.

DONE
 

·
Registered
Joined
·
240 Posts
you can indeed. I did it my self. The only problem you would have is that alfaobd won't let you write on the cluster odometer. And you would have to find someone to do it with some kind of aftermarket tool for altering the milleage on clusters....

write old cluster mileage if you care about it.
disconnect battery terminal cables (negative probably) on both batteries
remove old cluster.
connect new cluster.
assembly everything together.
coonect batteries terminal cables.

ALFAOBD part

body computer on car configuration change it to TFT Color Display
then proceed to do an proxy alignment.

DONE
I have a lifetime warranty and couldn't find anyone to do this for me in Michigan as it can be super sketch as odometer tampering is a pretty big offense unless it documented by reliable source. I ended up having my dealer install($300) and they couldn't change the odometer so they noted the mileage.

Not what I wanted but also didn't want to mess with my warranty and if for some reason I sell I don't get pegged for odometer tampering.

Anyway, I didn't disconnect the battery, just like my head unit that I changed 5" infotainment to 8.4" infotainment. It worked fine to disconnect while the battery is connected was connected(the dealer never does it when I have took in it for infotainment things). Just did a proxy align and blinking odometer went away but again I decided to go the route of the dealer based on some other factors.
 

·
Registered
Joined
·
76 Posts
I have a lifetime warranty and couldn't find anyone to do this for me in Michigan as it can be super sketch as odometer tampering is a pretty big offense unless it documented by reliable source. I ended up having my dealer install($300) and they couldn't change the odometer so they noted the mileage.

Not what I wanted but also didn't want to mess with my warranty and if for some reason I sell I don't get pegged for odometer tampering.

Anyway, I didn't disconnect the battery, just like my head unit that I changed 5" infotainment to 8.4" infotainment. It worked fine to disconnect while the battery is connected was connected(the dealer never does it when I have took in it for infotainment things). Just did a proxy align and blinking odometer went away but again I decided to go the route of the dealer based on some other factors.
How it was for changing from 5 inch screen to 8.4? Remllace stereo and ac controls if I'm not mistaken is the only thing to do?
 

·
Registered
Joined
·
240 Posts
How it was for changing from 5 inch screen to 8.4? Remllace stereo and ac controls if I'm not mistaken is the only thing to do?
You would lose that, but it is easier to just get a HVAC controller that has the dual zone and the knob for volume. Paid 35$ for mine from a local salvage yard. You get the dual climate buttons and get your volume buttons back. I actually have a extra 8.4 screen if you are in the market and I can tell your the options to change on alfaobd.

It is a couple more options because people upgrading from 7 inch screens is pretty much plug in play while from our 5 inch it isn't as easy. Not a headache now but it was for a second lol. Certain things took a second to figure out because our cars default BCM wasn't flashed for so much to be controlled by that system. A lot of trial and error but I am working 100% for almost a year now.
 
201 - 220 of 261 Posts
Top