My Jeep Compass Forum banner
261 - 280 of 312 Posts

·
Registered
Joined
·
11 Posts
I have the obdlink mx bluetooth and trying to modifiy the parameters in the BCM. I physically located that SGW, it is installed above the pedals behind the steering wheel accessories.
Due to SGW, any change was not possible. I ordered the Autel 8+12 cable, waiting it to arrive.
I have the Chrysler 12+8 bypass cable & OBDLink MX+. I can confirm I was able to disconnect the SGW wires & attach the cable/OBDLink MX+, connect to the body computer, & lock/unlock the doors using AlfaOBD. Based on this, anything else should be possible with AlfaOBD on my 2020 Compass Latitude.

14485
 

·
Registered
Joined
·
280 Posts
hey guys i'm having issues with my proxy alignment... so when i get to the part where its says its time to shut the car off, plug in the gray cable. Next turn on the car and wait until the car displays all of warning messages then press "ok" to continue... I'll look at alfaodb and its able to write the config to all of the systems EXCEPT the ABS system... its says its fails because its outside the parameters. As a result, everything is related to brakes is going off as a warning.... any help would be greatly appreciated its a "2018" latitude but it was manufactured in Dec 2017. This is with all the setting back too, basically my car is constantly saying there is no "surround sound system".. in order to change it, i had to enable it, do a proxy alignment. Then disable surround , and one more proxy alignment. and thats when all the "fun" happened. I upgraded to a 8.4" Uconnect last year and it came out of a salvage car. so my guess is the 8.4" is telling my car that it thinks there needs to be a surround sound system. who knows 🤷‍♂️
 

·
Registered
Joined
·
11 Posts
hey guys i'm having issues with my proxy alignment... so when i get to the part where its says its time to shut the car off, plug in the gray cable. Next turn on the car and wait until the car displays all of warning messages then press "ok" to continue... I'll look at alfaodb and its able to write the config to all of the systems EXCEPT the ABS system... its says its fails because its outside the parameters. As a result, everything is related to brakes is going off as a warning.... any help would be greatly appreciated its a "2018" latitude but it was manufactured in Dec 2017. This is with all the setting back too, basically my car is constantly saying there is no "surround sound system".. in order to change it, i had to enable it, do a proxy alignment. Then disable surround , and one more proxy alignment. and thats when all the "fun" happened. I upgraded to a 8.4" Uconnect last year and it came out of a salvage car. so my guess is the 8.4" is telling my car that it thinks there needs to be a surround sound system. who knows 🤷‍♂️
You might have some error codes in ABS that need to be cleared before your proxy alignment will succeed.
 

·
Registered
Joined
·
1,532 Posts
drBassman is spot on, when proxy alignments get hung up for me like that it usually means I need to use AlfaOBD to go into the various modules and clear a bunch of error codes, then try doing the proxy alignment again. It can be a tedious process.
 

·
Registered
Joined
·
280 Posts
Thanks for the suggestions drBassman/zelnaga. alfaodb replied and they said the following
Did you change anything in the car configuration? If yes, then it looks that the ABS doesn't accept the new settings, try to roll them back and re-run the alignment. You can roll back the changes one-by-one and run the alignment to find the one rejected by the ABS.
If you didn't change anything, try to disconnect the battery for a few minutes to reset the CAN bus and run the alignment again.
i did restore the setting in case if you all were wondering. I ended up going to the dealership for the proxy alignment and they did it FREE OF CHARGE. BUT when ended up happening is they fixed the ABS system but the radio was not allowing the proxy alignment to complete because the salvage car the 8.4' was pulled out of was had more features than mine 🙄... its always something.. i'm not afraid to get my hands dirty and try this again💪Since its winter im going to hold off trying again until the roads are better because the winters here are pretty tough some years.

Another Update: So the dealership must have done some sort of reset on the uconnect 8.4", now it says chrysler on boot up (no longer says jeep). backup camera no longer is working (acts like it does exist), and i no longer get the "surround sound is missing" when the car is turned on ... BUT not i get zero audio out of my speakers (my guess its trying to push audio to the non existing premium audio system 🤦‍♂️). Lol.... so i think the PLAN for right now is to put the very basic stock radio back in, get another proxy alignment done (to fix the audio issue and backup camera issue) and try again in the spring.
 

·
Registered
Joined
·
1,532 Posts
Has anyone used a less expensive OBD interface?? $99 is pretty steep for me. I was thinking about this one for $40...
Thats called a gamble. You can roll the dice on it if you want. End up wasting time and spending more money overall is what you risk (and as always with AlfaOBD, the risk of disabling part or all of your car). Your potential reward is saving $60. Next I suppose you are going to tell us you are splicing and soldering your own adapter cables for the different canbus modules...

I really wouldn't recommend it. AlfaOBD is not a polished, simple, easy, or reliable software as it is. Adding another variable to the precarious setup just isn't likely to be a fun time for you. Even with the recommended interface the procedures and proxi alignments fail regularly for no reason, the app crashes, stuff in the car crashes and buckets of error codes get set in the various car modules that all have to be cleared and battled with to get it back into a drivable state.

AlfaOBD is super, super sketchy. It barely works on our cars. Its support is almost non-existent. 90% of the developer's attention goes to the big name vehicles like the Dodge Ram. There is technically no warranty and the creator assumes no liability if it bricks or scrambles your car. If you do get any support, it tends to be "download this APK and sideload it" type of sketchy stuff outside of the Google play store, and maybe after a couple iterations the fix you needed will show up as yet another random menu setting in the options menu.

I had a glitch with the trailer tow module that prevented me from completing any proxi alignments and the dev eventually gave me an APK that had a hack workaround to use a different adapter cable and a one-off setting to enable the hack to work. Eventually that update made it to the play store version. If you have some weird issue like that you won't have any way of knowing if its your interface or something the developer needs to fix.

That program and its associated tools can really mess up your car too. My entire infotainment system spazzed out and died and although nobody knows for sure either way but it conspicuously happened right after I started playing with AlfaOBD and changing stuff on my car. Maybe the radio was already defective and going to die, can't say for sure. Suspicious either way though and a bad time having to have it replaced.





Moral of the story, AlfaOBD is barely worth the risk and the headache to start with. I really wouldn't recommend doubling down on its volatile potential by going off the beaten path and not using the recommended hardware. My car has been so screwed up sometimes from experimenting with AlfaOBD that I truly did not know if I was going to be able to get it back into a drivable state or if I was going to be calling to have it towed to the dealership.

If you are interested in AlfaOBD because you want to repeat something someone else has successfully done/changed and posted about here, I'd suggest you follow their narrow path with great precision. Stepping off a known-good path raises the risks tremendously.

If you are looking to change or do something that hasn't been documented as being accomplished on this car by others before, tread extremely carefully and make sure you are in a position to comfortably take the extra risks with your nice car.

Either way, probably use the recommended hardware.

If you are able to find evidence of others successfully using the cheaper interface with AlfaOBD on another forum for Dodge Ram, Jeep Renegade/Cherokee, Chrysler then maybe its safe to do so. If you can't find evidence of anyone else using that exact adapter with an FCA vehicle and AlfaOBD but you want to roll the dice anyways for the love of sixty bucks... good luck to ya.
 

·
Registered
2018 Jeep Compass Latitude 4X4
Joined
·
5 Posts
Wow, thanks for your opinion of me right off the bat... "Next I suppose you are going to tell us you are splicing and soldering your own adapter cables for the different canbus modules..." just because I want to save $60 that I love so much. It's not like I was thinking about getting the $7.95 interface off of eBay. I planned on getting the appropriate cables, you know, the ones that don't require soldering. I just asked a simple question and expected a simple answer. But I appreciate and thank you for the long answer of your own experience and sorry it hasn't gone smoothly for you.
 

·
Registered
Joined
·
54 Posts
would it be possible to share the BCM Proxy System configuration under this topic, will be helpful during choosing the options to enable or disable. for ex, I have many menus disabled in my EMEA LIMITED, pretty sure that US models have it, will activate them.
 

·
Registered
Joined
·
54 Posts
here is my log attached.

I give a try on the FCA bypass and grey cable and activate the Autolock Menu yesterday.
My main goal is to activate the Uconnect live app but I could not figure out the exact procedure yet, maybe I need to write a sales code to the uconnect module.
Any Proxy Configuration from european compass on which uconnect live app is avail will help actually as there are some keys in BCM proxy such as APPs PRESENT but I am not 100% sure, it is linked with U.S market Sirius Guardian etc or E.U market UConnect live, Jeep Skills etc.

I plan to work on below options, if u already succeed or failed on below options, your experience is important for me.
  • Disable Start&Stop
  • Disable Seat Belt Chime
  • Enable DAB radio
  • Global Windows down with keyFOB. (I guess Windows UP from keyfob will not be possible, this happens to me a lot. I generally notice sunroof or one of rear windows open, get in, put the ignition on, close the window and get off. Prefer to close the windows from the keyfob but not possible I guess. I actually wonder what is referred with "Window Auto Closing/Opening: Not enabled"
  • DRL menu
  • Oil information ( again is it avail in your config, any oil life information on IPC cluster?)
  • Intrusion alarm menu (not sure?)
  • Horn Chirp Menu
  • After wipe
  • Audio Repitition Menu
  • Signature Lighting (currently only DRLs active, LED strips do not come on AUTO. should be in park (ONwith DRLs)
Current State of LED strips: PARK: ON, LOW BEAM: OFF, AUTO: OFF

Regarding with PROXI ALIGNMENT, my notes as below as ABS is the last node in CAN, it stores the configuration mismatch errors.(also thanks for @mmdogan for this valuable information) Therefore, u need to clear the fault codes on ABS and BCM(if avail) before starting a new PROXI ALIGNMENT. In most common cases, TCM also catch a ECU mismatch and START & STOP DISABLED error comes on together with a MIL light on with Service the Engine message.. You need to connect gearbox module and clear the fault. That MIL also turns off. There is no need to repeat proxi alignment unless your odometer still flashing.

Regards.
 

Attachments

·
Registered
Joined
·
2 Posts
Hi everyone,
I've been following this thread for a while now. Thanks to y'all for all the great preliminary work with alfaOBD. Seems to be a promising tool.
I now got my OBDLink MX(+), my grey cable and obviously the current version of alfaOBD from the Android Playstore. Now I'm curious to also jump into the fun.
 

·
Registered
Joined
·
2 Posts
here is my log attached.

I give a try on the FCA bypass and grey cable and activate the Autolock Menu yesterday.
My main goal is to activate the Uconnect live app but I could not figure out the exact procedure yet, maybe I need to write a sales code to the uconnect module.
Any Proxy Configuration from european compass on which uconnect live app is avail will help actually as there are some keys in BCM proxy such as APPs PRESENT but I am not 100% sure, it is linked with U.S market Sirius Guardian etc or E.U market UConnect live, Jeep Skills etc.

I plan to work on below options, if u already succeed or failed on below options, your experience is important for me.
  • Disable Start&Stop
  • Disable Seat Belt Chime
  • Enable DAB radio
  • Global Windows down with keyFOB. (I guess Windows UP from keyfob will not be possible, this happens to me a lot. I generally notice sunroof or one of rear windows open, get in, put the ignition on, close the window and get off. Prefer to close the windows from the keyfob but not possible I guess. I actually wonder what is referred with "Window Auto Closing/Opening: Not enabled"
  • DRL menu
  • Oil information ( again is it avail in your config, any oil life information on IPC cluster?)
  • Intrusion alarm menu (not sure?)
  • Horn Chirp Menu
  • After wipe
  • Audio Repitition Menu
  • Signature Lighting (currently only DRLs active, LED strips do not come on AUTO. should be in park (ONwith DRLs)
Current State of LED strips: PARK: ON, LOW BEAM: OFF, AUTO: OFF

Regarding with PROXI ALIGNMENT, my notes as below as ABS is the last node in CAN, it stores the configuration mismatch errors.(also thanks for @mmdogan for this valuable information) Therefore, u need to clear the fault codes on ABS and BCM(if avail) before starting a new PROXI ALIGNMENT. In most common cases, TCM also catch a ECU mismatch and START & STOP DISABLED error comes on together with a MIL light on with Service the Engine message.. You need to connect gearbox module and clear the fault. That MIL also turns off. There is no need to repeat proxi alignment unless your odometer still flashing.

Regards.
I was wondering if you were successfull with two of your tasks:
  • Global Windows down with keyFOB
and
  • Signature Lighting
Did you get this to work? I'd love to have the Signature LEDs as "auto on" for DRL.
Also I'd be curious if it'd be possible to automatically activate the power folding mirrors whenever I lock the car.
Has anyone any experience on that?
I'd really appreciate your ideas and input! Thanks!
 

·
Registered
Joined
·
54 Posts
I actully did not find chance to check those. but also noticed that Italian guys found something strange.
They activated the rock mode and also the 4WD low together with hill descent, by replacing the swtich only. I am actually not sure if any additional wiring, valve etc required for transfer case, or only a switch change can handle this.


15065
 

·
Registered
Joined
·
7 Posts
I actully did not find chance to check those. but also noticed that Italian guys found something strange.
They activated the rock mode and also the 4WD low together with hill descent, by replacing the swtich only. I am actually not sure if any additional wiring, valve etc required for transfer case, or only a switch change can handle this.


View attachment 15065
Two clarifications: 1) I don,t replacing the swtich only but i use Alfaobd for change the configuration. 2) I haven't been able to activate yet the Hill Descent Control
 

·
Registered
Joined
·
7 Posts
welcome phoenix;)
Yes you referred that "Rock mode and 4WDLow work perfectly". I thought that "hill descent control" is also working.
Hi Zelnaga and thanks
You thought wrong. I tried without success. My "Hill descent control" setting is already enable by default. I try with: "ABS Funct - Selection speed Control/Hil descents (Dart)"
but it does not work
 
261 - 280 of 312 Posts
Top