My Jeep Compass Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Skid lights and I believe esp lights have come on a couple of times while driving and I cannot go over 10 mph.i have turned off the car and back on again and usually goes away but last time I was on a country parkway (very out of the way) with family and it happened again and didn't go away right away after the on/off troubleshoot.it was very unnerving.
So I turned off the esp after it was working again but getting bad mileage and whenever I turn it back on again the skid light comes on.
Any help would be appreciated as I have a road trip in a couple of weeks

Thanks!
 

·
Registered
Joined
·
442 Posts
Skid lights and I believe esp lights have come on a couple of times while driving and I cannot go over 10 mph.i have turned off the car and back on again and usually goes away but last time I was on a country parkway (very out of the way) with family and it happened again and didn't go away right away after the on/off troubleshoot.it was very unnerving.
So I turned off the esp after it was working again but getting bad mileage and whenever I turn it back on again the skid light comes on.
Any help would be appreciated as I have a road trip in a couple of weeks

Thanks!
Hi Compassnyc2007,

What year is your Compass? Is it a 2007, or is it newer/still under your basic factory warranty? If you need help getting in to your Jeep dealership for service, let us know!

Kori
Jeep Social Care Specialist
 

·
Registered
Joined
·
29 Posts
throttle body or wheel speed sensors. pull the fuse for abs pump if its still doing it its the throttle body. exact same thing happened to me last month was 750+(cad) at stealership to replace gm also has it listed as a dealer only part here as well ended up geting one online and installing my self(4bolts and a plug pull batery and intake hose everything is accessible.
 

·
Registered
Joined
·
272 Posts
I would definitely point straight to wheel speed sensors but I didn't know the throttle body could do that as well. That's an odd one. I would try to eliminate the wheel speed sensor first though as it seems to be the most common thing that would do it.
 

·
Registered
Joined
·
29 Posts
i was told the throttle body has plastic gears and they can strip. so it will try to accelerate and then skip and the plate lowers inside the body causing a small stall feeling then when the car senses enough(or big a big one it will put the car into limp mode to protect it.) the jeep dealership tech that looked at it was saying water can get into it and freeze and that what could cause the stripping of the gears. i was also experiencing sluggishness when i would exit the highway it would feel like the transmission was skipping but also these are the same symptoms as the wheel speed sensors so defiantly start with them as they are 40-100$(part) i think.
 
1 - 5 of 5 Posts
Top