My Jeep Compass Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi, I'm a young adult and first time car buyer. Last year in the month of December I got the 2018 Jeep Compass Latitude. The salesman handed me the keys and told me that the light with the "A in the circle with !" just meant the car key battery needed time to sync with the car (they had replaced the car key batteries with brand new ones). He said that the light would disappear in a few days. Obviously I'm writing here because it's been almost 2 months and the light is still on. Yes, I've been on multiple appointments now (taking advantage of the warranty while I still can) and the light is still on even though they said they've fixed the problem. I'm not mad at the service crew, I just want to know what are the main causes/ reasons and the most common way they fix it. I know the auto stop start problem might not be a big deal to not have fixed but I want to make sure my car has nothing wrong with it all. I'm planning on asking the nice man who's been helping me with this car, but I'd also like to hear from you guys. Thanks for reading!
 

·
Registered
Joined
·
5 Posts
RoseBug,

I recently purchased a 2019 Jeep Compass Limited. I too have the same warning light on and didn't notice it when I was test driving the vehicle. I also noticed under the message area of the dash, a warning that the Auto Start/Stop is not working.

In addition, I have found that the red light beside the gear selector which shows you which gear your in is not lighting up when I take the care out of park. It does flash temporarily when I start the car but then it goes out and does not change to indicate if I am in reverse, drive, etc..I have to see what gear position I am in by looking on the dash. Finally, I am noticing some odd glitches with the Uconnect navigation system.

The vehicle has the factory warranty so I plan to take it in and have everything checked but I am trying to find out if others have had similar issues and what the resolution was.

Good luck.
Chris
 

·
Moderator
Joined
·
1,050 Posts
There are a couple threads about this. You might try using the search bar above. Its hard to see because its dark gray against a black background. It says "Search Community."

My start/stop is quirky but it doesn't usually flash the warning for more than a day. When it is severely cold I frequently get the dashboard warning, "Auto stop/start not available, outside temperature too cold." Usually after it run it long enough to warm up the warning will go away. During this stay-at-home order I hadn't used my Compass for several days and it gave me the warning on Tuesday when it was barely below freezing. This time it didn't reference the temperature, it just gave the the arrow circling the A icon. Again it went away after awhile. These things are definitely quirky. However, make them fix it right while its under warranty. In my state you can't get an inspection sticker with any dashboard warnings.
 

·
Registered
Joined
·
5 Posts
There are a couple threads about this. You might try using the search bar above. Its hard to see because its dark gray against a black background. It says "Search Community."

My start/stop is quirky but it doesn't usually flash the warning for more than a day. When it is severely cold I frequently get the dashboard warning, "Auto stop/start not available, outside temperature too cold." Usually after it run it long enough to warm up the warning will go away. During this stay-at-home order I hadn't used my Compass for several days and it gave me the warning on Tuesday when it was barely below freezing. This time it didn't reference the temperature, it just gave the the arrow circling the A icon. Again it went away after awhile. These things are definitely quirky. However, make them fix it right while its under warranty. In my state you can't get an inspection sticker with any dashboard warnings.
Thank you for the info. I actually bought my vehicle online (you see the ads with the vending machine) on TV. I am not sure about naming company names here. So when they delivered it, I did not notice the warning at all. Several days went by and I discovered it. My warning stays on all the time and of course, the feature is not working.

I have several other issues too and hope it's not going to be a lemon. It's the first Chrysler product I have owned and so far I am disappointed to say the least. I like the vehicle but these issues are concerning and my confidence in the brand is low. My last vehicle was a 2003 and I had no issues at all but I was concerned about the age and potential problems in the future so I decided to buy this one. I am a first responder and often drive in bad weather to get to headquarters, so a dependable vehicle is a must. Now, I have a 2019 and have already had more problems in two months then I had in 18 years with my old vehicle.

Thank you for your comments, I will let you know if I find out anything moving forward.

Best Regards,
Chris
 

·
Registered
Joined
·
1 Posts
have your main battery 12v battery checked if the voltage is to low or the battery is too weak the auto shut off will stop working. Hope this helps.
 

·
Registered
Joined
·
9 Posts
That same warning light on my 2017+ Compass Sport came on one day as I was pulling into a gas station. It went off after I restarted the car. I noticed the next day that the Stop/Start feature had stopped working.
It took two trips to the dealer, but they finally found the problem. They replaced both batteries, and it has been working fine since. Luckily it was still under warranty, so they didn't charge me.
 

·
Registered
Joined
·
2 Posts
I took my Compass to Jeep twice for this and they finally fixed it. It was a battery issue. The car would sometimes shake or shut off when start/stop would kick in. Haven't had the problem since.
 
1 - 7 of 7 Posts
Top