My Jeep Compass Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
My wife has a 2007 Compass limited. Yesterday she told me it was ticking. i get home and its running quite and just fine. Today she is pulling in from work and as she idled down the driveway it sounded like it was rattling. I pin pointed it to something that is running on the belt. I removed the belt and the sound is gone. I came in from work and it took 30 min to get the sound to come back. I took both idler pulleys off and theres a very small groove in each one, but they spin free and doesnt' seem worn out.

Has anyone else had this rattling problem? It will drive me nuts!! could it be these pulleys or the tensioner?
 

·
Registered
Joined
·
1,897 Posts
Could be the ADP on the alternator. They were know to fail early on that year.

That job is a PIA though. Good luck there is a short video made here but only confirms how much you have to go through to get it out etc.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #3
Thanks,
I replaced the idler pulleys and the belt today....still makes the noise, Alt pullet has some wiggle to it. I figured Id replace the whole thing, but I gotta find out which one I have, 115 or 140 amp, before I go by it. Ive been searching and havent found anything yet, on how to tell.
 

·
Registered
Joined
·
1,897 Posts
I had the dealer check once on my build and it was not 140A. I don't know what configuration they would be putting that in. I have enough power options in my package including heated seats but not the bigger alternator though.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #5
I was able get my phone close enough to get a pic. I was able to get the numbers and googled it, and found that its a 115a. Then after looki g at the pic again, it has a number 115hs.....so i bought one off a 2012 wrecked jeep for 40.00 with warranty!!!
 

·
Registered
Joined
·
1,897 Posts
Well done, I used to see ones pulled out of wrecks on eBay cheap with low millage. The ADP is usually the first thing to go. Shaft bearing next.
 

·
Registered
Joined
·
27 Posts
2012 Compass

Our 2012 Jeep Compass Limited has the 2.4 engine, when first started in the morning, engine cold, I can hear a clacking noise, probably lifters that continues until the engine has warmed. I am using the Royal Purple Synthetic 5w-30w, along with there filter. Can't imagine what else it could be. We have 35k on the odometer at this time and the engine runs just fine after its warmed to operating temps: Anyone else had this problem and does it get worse with age?
 

Attachments

·
Registered
Joined
·
1,897 Posts
Lifters are a tapping noise. It should not make any noise in these engines. At 35k is nothing and I'd be really worried later on. Have you taken it to the dealer (any dealer), that's the first step if not.
 
1 - 9 of 9 Posts
Top