My Jeep Compass Forum banner

1 - 20 of 31 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have seen a lot of good discussions on here about the same problem I have with my 2014 Compass, with 5,000 miles on it, but the discussions are long on complaint descriptions but sadly short on answers. Perhaps someone has updated information? When I am stopped at a stop light with my foot on the brake, there is a lot of engine vibration. If I take my foot off the brake the vibration stops, but it starts again when I step on the brake. If I move the gear shift from drive to either neutral or park the vibration stops and does not return when I go back to drive. I went to the dealer who told me they can't ascertain the problem without hearing it, but it happens for only a short time each time I have started the vehicle. With all the comments on here about the problem, I would think the dealer should know about it.
 

·
Super Moderator
Joined
·
534 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thanks

Thanks for the service bulletin. I took it and several of the comments from others showing the same problem from 2008-2011 models to my dealer today and he said none of them matter because my car is a 2014 model so we are comparing "apples to oranges." I said no, we are comparing green apples to red apples; clearly this is an on-going problem with the Jeep Compass because we see so many complaints about it over time, but I just can't find any right now for 2014 models because the car is a new model. The things he said can't really be believed. He said that car models change completely from year to year so no problems from one year can mean anything to another year. Of course it is all nonsense, but what can one expect from a car dealer? My car is one year old and my wife is scared to drive it (and I'm angry to drive it) because of this vibration. The simple truth is that Jeep doesn't care. We are seriously thinking about trading it in for a Subaru Forester after only one year and 5,000 miles. I only want a reliable car, but these dealers have an answer for everything that develops; unfortunately, in a case like this, the answer is basically a shrug.
 

·
Super Moderator
Joined
·
534 Posts
The only difference, with your 2014 would be that you have an 6 speed automatic transmission vs the CVT of all the prior years, you will have a CVT in your 2014 if it is the FDII trail rated one.

Regardless a transmission change isn't going to change the issue you are having.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Possible Fix

I also took the advice of several people on this board and told the service man that if they couldn't fix the car this time I would make a complaint to headquarters in Detroit. Perhaps this was a strong motivating factor, because they kept the car from 7:30 a.m. to 5 p.m. and when they pulled it off the rack at 5 p.m. they said they had replicated the problem and solved it. Because it is intermittent I won't know for sure for awhile. They say they found "retainers (speed nuts) loose allowing heat shield above cat. converter to rattle, tighten all retainers." I have tried to analyze this. We know the problem is related to the transmission, because it only occurs when the car is in drive and it stops when put into neutral or park and it doesn't recur (at least in the short times of a stop light) when put back into drive. Maybe, therefore, we are talking about different frequencies in the transmission when in drive, which causes the vibration in the heat shield, as opposed to the frequencies in the transmission in either neutral or park which then dampen the vibration in the heat shield. If the problem recurs in the future I will update this blog, but if we have a fix it could help many people who have had the same problem. Just maybe I was unfair with the dealer!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Fix Didn't Work

First drive this morning I started getting the same old vibration in my driveway. I'm not going to worry about it any more. Jeep doesn't seem to know how to solve this so we are going out today to trade it in for a new Subaru Forester. We owned this 2014 Jeep Compass for exactly thirteen months and we have 5,100 miles on it. I am 59 years old, I have owned about ten cars in my life, and all of them have been American. I think it is time to try a foreign car. My friends have said for years that many foreign cars are more reliable than American cars. Now I will see first hand. Consumer Reports likes the Forester.
 

·
Registered
Joined
·
1 Posts
I am having the same exact problem, took it to the dealer, of course the sound didn't happen on that day. I am planning to take it again.
 

·
Registered
Joined
·
1,897 Posts
One needs to be very clear on describing the problem many times the service rep assumes one thing when its quit another. Especially if it can't be replicated the mechanic has not idea what he is looking for if he has the wrong information. You words are not what is on the work order and he never talks to you.

You need to be specific as to what you mean by vibration if thats the word used. Vibration: Sound only, sound and shaking, shaking only and where it feels like its coming from if you have a sense of it. Also WHEN, under what conditions.
 
  • Like
Reactions: hotvak123

·
Registered
Joined
·
1,897 Posts
Re reading the first post. But not know what transmission you have.

- tranny
- motor mount
- engine idle issue (Crankcase position sensor related)

These would be my suspect areas. Its a shame to dump a like new vehicle when it should be able to be fixed. I assume they've not found any codes which is a dealers first thing they do. Software updates as well.

There may be differences from year to year but its not completely new and many design problems are not fixed. But addressed if they occur if they fail during warranty.

Good luck
 

·
Registered
Joined
·
10 Posts
Mounts mounts mounts. They need to all be checked. I have seen this on many different vehicles of many different years makes and models. More than likely you have 1 of 2 problems occurring. There is either a broken(or loose) mount bolt in one of the engine mounts or the transmission mount OR the urethane rubber mount material(dampener) has torn or become worn out prematurely.

The problem you are narrowing down to be a transmission problem because it's only when you are in gear actually very well may not have anything to do with the transmission but more so the reason you only feel the problem when stopped but in gear is because that is when the engine is "under load" thus causing vibrations to be transferred to the mounts. The urethane dampeners in the mounts would normally absorb those vibrations but if there is a problem with the bolts or the urethane... vibrations then transfer through the mounts and into the body of the vehicle.
 

·
Registered
Joined
·
213 Posts
"Mounts mounts mounts." Absolutely. Long standing Chrysler tradition: cheap out on parts like mounts or suspension. I had a '94 Grand Caravan that was absolutely smooth when new. After only about 30,000 kms it started vibrating, took it back to the dealership and the service manager said 'they all do that'. We walked around the lot and started up a few other vans and they were all the same, including their customer shuttle van.

Also see "ballast resistors" ;-)
 

·
Registered
Joined
·
1,897 Posts
I believe he implied the motor mounts were the problem. I had a 1997 3.0L Caravan and did not have much parts problems other than rusting routers which was the quality of the steel. Replacements were cheap for it and lasted longer. I believer that was before FIAT took over what was happening. I had my Compass in for a tire follow up from a replacement I got. The front end ball joint and rod ends from aftermarket parts are holding up well. About 60-80K on them but not done altogether so its variable.

Others here have had motor mount failures as well if you go back into older threads.
 

·
Registered
Joined
·
1 Posts
I have a 2016 jeep compass sport 4x4 and i have engie vibration when in drive at stop light or stop sign, took to 2 jeep dealerships and they find anything wrong, i contacted jeep and was told to take to another jeep dealership and they would help with the problem. I have had my jeep for almost 1 year and this has been going on for almost that long. Anyone else have this problem? If so please sdvise what was done? Thanks
 

·
Registered
Joined
·
92 Posts
Call me crazy, but this all stopped when i put about 20000 miles on the vehicle.. i also installed a cold air intake / cat back exhaust.. this car runs much smoother since i did that.. i wouldnt doubt that the factory exhaust is causing so much back pressure that the engine runs "rougher" and causes it to vibrate a bit more... 4 cyclinder engines in general vibrate a lot more than V shaped engines.. thats my w cenrs haha. Clean the throttle body once in a while or run seafoam / fuel injector cleaners every 3k miles... This is what ive done in the past and my engines alwats ran tip top without major failures
 

·
Registered
Joined
·
38 Posts
vib

I had the same problem but I fixed it when I noticed when the hood was closed the rubber contact point at the front corner of the hood was not touching and would vibrate. I turn the rubber adjuster up and it went away.
 

·
Registered
Joined
·
2 Posts
Hi, I just bought a 2016 Jeep Compass about 3 weeks ago, my husband today had accidentally put it in 1 then 2 then 3 and then 4 when we pulled over and tried to put it back in drive it was making this weird loud sound that sounded like there was something wrong with the engine. It is a loud sound, that when in N it don't do it but when you are driving it and sitting still at a stop sign it is really loud. It don't do it in park, Neutral or Reverse. It is only when in drive or when you have the foot on the brake. It just started to have a clicking sound when you press the brake to put it in Reverse. It only has 30,405 miles on it. What could be the problem? It sounds like a lot of you have the same issue but with other vehicles and longer miles.
 

·
Registered
Joined
·
437 Posts
Hi, I just bought a 2016 Jeep Compass about 3 weeks ago, my husband today had accidentally put it in 1 then 2 then 3 and then 4 when we pulled over and tried to put it back in drive it was making this weird loud sound that sounded like there was something wrong with the engine. It is a loud sound, that when in N it don't do it but when you are driving it and sitting still at a stop sign it is really loud. It don't do it in park, Neutral or Reverse. It is only when in drive or when you have the foot on the brake. It just started to have a clicking sound when you press the brake to put it in Reverse. It only has 30,405 miles on it. What could be the problem? It sounds like a lot of you have the same issue but with other vehicles and longer miles.
Hi liltiggerlvr,

If you decide to visit your local dealership for further diagnosis I'd be happy to follow up with them for you if needed. Just PM our page with your VIN and let me know!

Andrea
Jeep Social Care Specialist
 

·
Registered
Joined
·
1 Posts
I have this same problem with my 2015 Jeep Compass. When it's in park it's okay but when I'm in drive and have my foot on the break it is so loud!
 

·
Registered
Joined
·
213 Posts
Hi liltiggerlvr,

If you decide to visit your local dealership for further diagnosis I'd be happy to follow up with them for you if needed. Just PM our page with your VIN and let me know!

Andrea
Jeep Social Care Specialist

I'm just thinking, wouldn't it be nice if dealers would actually diagnose and repair the problem? ie, do their job. Instead of customers getting told 'there is nothing wrong' or 'they are all like that' and forced to try dealer after dealer to find one who can help? Particularly when it is a very obvious and recurring problem? This is the same old Chrysler dealership crap as has happened for decades, I'm just wondering if it will ever stop.

Don Cooper
 
1 - 20 of 31 Posts
Top