My Jeep Compass Forum banner
41 - 44 of 44 Posts

· Registered
Joined
·
2 Posts
Hello, this has also been happening to me. We tried to take it into Jeep and it was there for two weeks of noting getting done to the Jeep. And they still wanted to charge $200 just to see it. Which is stupid, because nothing was found. Here is a tip though! If you read the owners manual it has something in there about it. It says to put your car into N. This has saved me a lot! Because it is scary when you are on the high way and this happens. I have also been turning my auto start off too. This has seemed to help. But I also haven’t found a solution to fixing this. Shouldn’t it be a recall.?
 

· Registered
Joined
·
2 Posts
Since I purchased my Jeep Compass Trailhawk in February 2019, sporadically a message appears on the dashboard display about "High Coolant Temperature" and immediately sends the vehicle to shut down and after a couple of seconds the error disappears and the temperature returns to normal. I must clarify that at no time does the vehicle overheat. This error occurs at any time of the day, regardless of whether the vehicle is cold in the morning or after driving for several hours; sometimes it occurs several times a week and sometimes not at all for weeks; the vehicle may be stopped at a traffic light or in motion on the highway, a particular situation that worries me greatly, because when this happens, the vehicle locks up for an instant (approximately one second) in which the steering hardens and the vehicle tends to stop abruptly, and I fear that this may cause damage to my car or even worse cause an accident. This situation has been reported since the first time it happened (about 18 months ago) and I have had to go to the garage about 20 times. In each occasion the technical team has tried to solve the problem without success, they even replaced a control module, installed updates, ran the scanner, and made long driving tests trying to recreate the condition that causes the error without succeeding. I would like to know if anyone else has had this problem and what solution they have been given in the workshop, perhaps it could be the temperature sensor. Thank you for your comments!
This is happening to me!!!!! Did you figure out why? Mine has happened randomly at first I thought it was when I ran the heater, but that wasn’t it.
 

· Registered
Joined
·
714 Posts
This is happening to me!!!!! Did you figure out why? Mine has happened randomly at first I thought it was when I ran the heater, but that wasn’t it.
Hi there!

If you plan to visit a dealership for this, we are happy to help. Feel free to contact us via private message to get started.

Kate
Jeep Cares
 
41 - 44 of 44 Posts
Top