My Jeep Compass Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
So, i was sitting at a Stop sign waiting my turn and this crazy driver (with a learners permit, and she's been trying to learn to drive for three years) Plowed into my front right smashing it all to tiny tiny bits. (wiping out half of my 1500 can$ front end work done not 4 weeks before..) long story short it cost my insurance company almost 5k to get everything back up to spec....

so i got my 08 Compass 2.4l North Edition 4x2 back, and ever since my fuel millage is horrible with one exception, so i felt my consumption was way way up so i called the shop about 50km after i got it back and they told me to take it to Fill up and run 100km and fill up twice since my tank was basically empty before the accident ( was on my way to wally's world then the gas station) so i just kept going to 100km and filling up... to my shock and surprise that cost me 24.24L (or 9.70 US MPG) mind you it was all surface no highway driving... however my average consumption for the same driving is about 12 L/100km or 16mpg (rated at 9.7L/100km or 23mpg)

the shop said do it twice, so i did the second run now this time i did 70% highway on the second run. now this is were it gets realllllly weird.... i got 12L/100km / 16mpg on that run.

I am doing a third one as i really don't understand and i am wondering if it just an anomaly that first run and at 50km i was past the 1/4 tank and now at 80 i am not not quite at 1/3 the tank....

now here's the problem, at highway speeds everything is well upto my std consumption, but at low speeds it's almost double. my goal is to finish the 100 by tonight I'll post the results of that... but.... i don't understand what might cause this drastic fluctuation of consumption. does anyone have any idea what it might be? of course the insurance company did not look inside the engine and they are likely going to have to do that.... but i am just wondering...
 

·
Registered
Joined
·
28 Posts
Did you see any difference in the engine's performance before and after ?

After a longtime park, no gas on the ground ?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
yeah that was my first thought. so every morning and most of the times that i would leave a spot i would check for fluids on the ground... just A/C water is the only thing i am finding.

See but what is really running me for a loop is the second 100km run that was 33km at 50max and 67km highway at 120. was down to 12l/100km.

I did not finish my third 100km run last night as i was hoping... but that will be done on the way home from work today. and a i am awfully close to the 1/2 mark with about 5km to go.

as for the performance it's a little rougher when under throttle now that i thing about it. not that it's going to stall but just rougher..

I am pretty sure that the car stopped just a inch or 2 from my engine block and it was still running until i turned it off after the accident. I am pretty sure the shock of the other driver not breaking before she hit me got transferred into the engine in some way shape or form. the battery and everything certainly got pushed towards the engine.
 

·
Registered
Joined
·
28 Posts
I don't like this method. Drive normaly to fill down the tank (45 l before the led on the dashboard), then fill up this one and calculate manually the average.

Have you got CVT or manual ?
 
1 - 4 of 4 Posts
Top