My Jeep Compass Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi Everyone!
Last year I purchased a 2018 Jeep Compass Trailhawk and although it’s had a few issues it’s been a great little car.
I’m leaving on a 2 week trip next week and of course a few days ago it start having an issue I can’t figure out. When I first turn on my car the area next to the shifter that indicates what gear the car is in blinks a couple times then goes dark and remains dark for the duration of the drive. It drives normal and seems fine other than that and no service lights ever go on. Its just annoying when driving it in the dark.
Has anyone here seen anything like this before?
 

·
Registered
Joined
·
2 Posts
I scheduled a service in Turin (Italy) around first of July (the first date available) because isn't too important issue, I will not forget to update with news.
 

·
Registered
Joined
·
18 Posts
Same issue here on a 2020 with 7400 miles. The P blinks red then all the lights on the shifter go dark. It drives fine. I have scheduled an appointment to drop off next Saturday.
 

·
Registered
Joined
·
24 Posts
I dont know if you got it handled but I took mine in under warranty and they replaced the entire shifter mechanism. Which makes me think it’s not an easy bulb replacement or wire or something.
 

·
Registered
Joined
·
18 Posts
It works when it wants to. The dealer basically told me unless it is dead when I bring it up there they can't really do anything with it. Funny enough, it worked an entire week before my appointment, stopped the night before, then started again the day of my appointment. The Jeep drives well, so I will just keep on going down the road with it.
 

·
Registered
Joined
·
146 Posts
Well I finally went to my dealership today ( Papa’s Jeep) as the shifter lights were not working. I left my Jeep on while I went inside and the shop Forman came out to look at my Compass. He stated he knew exactly what the problem was and pulled my Compass in to take a look. A few minutes later he came over and let me know he confirmed the problem and that there was a bulletin out for the issue. It’s a software issue and all that needed is a update to fix.
He performed the software update and I got my paperwork and was good to go. So far it’s working fine.
Code was stored in Ecu was PO814-00 The TSB is #08-051-20 Transmission range display circuit fault, update was performed and took .2 of an hour to complete. Covered fully under mfg warranty.
Also TSB #18-035-19 rapid response transmitted flash of power train control module was performed. Not sure what that one was but they did it.
While performing update found my drivers door lock faulty and ordered new door lock actuator. While I haven’t had an issue with the door I’m glad it’s been found and will be corrected.
Hope this helps all who have an issue get theirs corrected.
 

·
Registered
Joined
·
34 Posts
Started doing this to me about a month ago during a heat wave. From my experience the interior electronics (it's an LED) don't get along really well in 95°F ambient or above. Everything else works fine so I'll handle it with the oil change but it irks one of my peeves about stuff not working in the meantime.
 

·
Registered
Joined
·
81 Posts
I guess you gotta add it to the Compass quirk list. Mine started doing this a few days ago. Randomely flickers then lights out. Then usually by the time your at your next start stop situation, it'll work fine.
I'll hafta see what the dealer is going to charge me to do the TSB, or do I just live with it. Hard to justify $120 (hr labor) for a 15 minute download........to fix a defect on their product!
 

·
Registered
Joined
·
1 Posts
Hi Everyone!
Last year I purchased a 2018 Jeep Compass Trailhawk and although it’s had a few issues it’s been a great little car.
I’m leaving on a 2 week trip next week and of course a few days ago it start having an issue I can’t figure out. When I first turn on my car the area next to the shifter that indicates what gear the car is in blinks a couple times then goes dark and remains dark for the duration of the drive. It drives normal and seems fine other than that and no service lights ever go on. Its just annoying when driving it in the dark.
Has anyone here seen anything like this before?
PLEASE UPDATE ME! I have the exact same problem and can't figure it out.
 

·
Registered
Joined
·
34 Posts
It's a software flash at the dealership. It takes about 10 minutes, I had them do it when I had the oil change. No issues since.
 

·
Registered
Joined
·
2 Posts
Hi Everyone!
Last year I purchased a 2018 Jeep Compass Trailhawk and although it’s had a few issues it’s been a great little car.
I’m leaving on a 2 week trip next week and of course a few days ago it start having an issue I can’t figure out. When I first turn on my car the area next to the shifter that indicates what gear the car is in blinks a couple times then goes dark and remains dark for the duration of the drive. It drives normal and seems fine other than that and no service lights ever go on. Its just annoying when driving it in the dark.
Has anyone here seen anything like this before?
Same problem here too
 

·
Registered
Joined
·
2 Posts
Did
Hi Everyone!
Last year I purchased a 2018 Jeep Compass Trailhawk and although it’s had a few issues it’s been a great little car.
I’m leaving on a 2 week trip next week and of course a few days ago it start having an issue I can’t figure out. When I first turn on my car the area next to the shifter that indicates what gear the car is in blinks a couple times then goes dark and remains dark for the duration of the drive. It drives normal and seems fine other than that and no service lights ever go on. Its just annoying when driving it in the dark.
Has anyone here seen anything like this before?
Did your one fixed ☝☝
 

·
Registered
Joined
·
18 Posts
Same issue here on a 2020 with 7400 miles. The P blinks red then all the lights on the shifter go dark. It drives fine. I have scheduled an appointment to drop off next Saturday.
Changed to a different dealer. This one didn't care that it was working correctly when I pulled up for service. It works for a few days, goes out, then comes back on. They diagnosed it as a faulty shifter, so the entire thing is being replaced under warranty in a few days. Also makes me thinks it's not just a simple bulb.
 
1 - 20 of 24 Posts
Top