My Jeep Compass Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello,
So I have a 2016 Jeep Compass. CVT engine. I’ve been having issues and took it to the dealership I got it from (Haasz Automall of Dalton) to have it serviced. The code is transmission Range sensor A circuit low (P0707). I replaced that sensor and never resolved the issue. What it’s doing- the square that’s around Drive (D) either glitches out, all gears have the square around it, or none of them have it at all. When it does that it doesn’t want to go while driving. The more I drive it the worse it gets. They also replaced the accelerator pedal which did absolutely nothing.
Has anyone had this problem or know how to fix it?
Please help! I’m about to lose it.
Thank you!
 

·
Registered
Joined
·
454 Posts
Hello,
So I have a 2016 Jeep Compass. CVT engine. I’ve been having issues and took it to the dealership I got it from (Haasz Automall of Dalton) to have it serviced. The code is transmission Range sensor A circuit low (P0707). I replaced that sensor and never resolved the issue. What it’s doing- the square that’s around Drive (D) either glitches out, all gears have the square around it, or none of them have it at all. When it does that it doesn’t want to go while driving. The more I drive it the worse it gets. They also replaced the accelerator pedal which did absolutely nothing.
Has anyone had this problem or know how to fix it?
Please help! I’m about to lose it.
Thank you!
Hey, Shumrichouser. Has your concern been resolved at this time? If not, we would be happy to discuss further. Send us a private message with more details.

Kate
Jeep Cares
 
1 - 3 of 3 Posts
Top