My Jeep Compass Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Well I'm on break at work reading my e-mails, and I see I have a new Jeep vehicle history report. I open the email expecting it to be ok. But I'm wrong. It states that my malfunction indicator light recently lit. Besides the 10 or so high wind warnings courtesy of SIRIUSXM on the NAV screen. I had no other warnings, or lights. So I go back to the car, expecting to see the warning light on. But no light, so I drive home, and no light. I check stored messages in the EVIC, zero stored messages. Last but not least I check to make sure all bulbs work at start up. They do and all go out. I'm at a loss. I don't want to be without a car, for a problem that I don't even think I have. Has anyone have any weird alerts?

By the way we have two other FCA products, a Grand Cherokee and a Scat Pack Challenger. Both with NAV, that receive health alerts, from u connect access, and never received an inaccurate report.
 

·
Registered
Joined
·
927 Posts
What I just found out yesterday was only the 2017 Compasses with navigation even have uconnect access or SiriusXM Guardian capability, so that means a whole bunch of us can't relate because we don't get a cool phone app to start and unlock our car with and no email reports or anything like that. Pretty weird because ours is a 2017 Limited with the 8.4" screen but, no nav = no connected services (at least for the 2nd gens stickered as a 2017 model, less sure about the 2018s).
 

·
Registered
Joined
·
41 Posts
This happened to us in our Trailhawk a couple months ago - same thing. We got an email that our engine malfunction light had come on, but there is no light lit on the dash. To be safe, I made a service appointment - but there were no codes. We have gotten a second email that it happened again - we ignored it, because again, there is no indication on the dash of a problem. I'm guessing a bug in the system.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #4
What I just found out yesterday was only the 2017 Compasses with navigation even have uconnect access or SiriusXM Guardian capability, so that means a whole bunch of us can't relate because we don't get a cool phone app to start and unlock our car with and no email reports or anything like that. Pretty weird because ours is a 2017 Limited with the 8.4" screen but, no nav = no connected services (at least for the 2nd gens stickered as a 2017 model, less sure about the 2018s).
Yeah it's like that on the older versions of the 8.4 also. I didn't need or want NAV, but every limited with advanced lighting and security package had it. That package was a must, so I'll have to deal with it. I really didn't feel like ordering one.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #5
This happened to us in our Trailhawk a couple months ago - same thing. We got an email that our engine malfunction light had come on, but there is no light lit on the dash. To be safe, I made a service appointment - but there were no codes. We have gotten a second email that it happened again - we ignored it, because again, there is no indication on the dash of a problem. I'm guessing a bug in the system.
Thanks for the reply. I'm going to do the same and ignore it for now. If it happens again I'll make a appointment.
 
1 - 5 of 5 Posts
Top