My Jeep Compass Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Mostly everytime I turn on the engine, the interior air fan switches by itself to the max and the interior temperature goes down to Low. It seems it resets by itself. Is this happening to others too?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
This is a well known thing and a fix is available at your friendly Jeep Dealer. Just ask for the update.


Thank you. I wonder why they didn’t make it a recall if it happens to every jeep compass 2nd gen.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
87 Posts
The dealer said they replaced a control module for my 2nd gen Compass but it's acting exactly the same. This makes me believe it's a programming issue. I'm noticing this during temperature change and sometimes during remote start.
 

·
Registered
Joined
·
415 Posts
The dealer said they replaced a control module for my 2nd gen Compass but it's acting exactly the same. This makes me believe it's a programming issue. I'm noticing this during temperature change and sometimes during remote start.
Hi jjcom,
We're very sorry that you are still experiencing this. Please feel free to send us a private message if you plant to continue working with your dealer to have this addressed. We are happy to provide you with additional assistance.
Lydia
Jeep Social Care Specialist
 

·
Registered
Joined
·
48 Posts
It says invalid thread id.


Sent from my iPhone using Tapatalk
Not sure how the link got messed up. This is the TSB mentioned: TSB # is 24-011-18. A Google search only pulls up that thread, so that's why I'm not so sure it's valid.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
10 Posts
Discussion Starter #13
Not sure how the link got messed up. This is the TSB mentioned: TSB # is 24-011-18. A Google search only pulls up that thread, so that's why I'm not so sure it's valid.

Sent from my Pixel 3 XL using Tapatalk


Google search using what terms?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
48 Posts

·
Registered
Joined
·
166 Posts
Happens to mine. Mostly seems to happen during remote start, but I have also had it happen during pushbutton start.
 

·
Registered
Joined
·
32 Posts
So I have been having this issue. I go into work setting my climate control to 76* with defrost and feet and come out hours later to have the driver side on hi and passenger on low on defrost. It happens about every 20th start. Remote start or push button it doesn't matter.

Well I took it in today to be told by the dealer that it's a normal feature. Apparently when the climate control feels its cold outside it will determine what it needs and adjust itself. I do not believe that what's so ever. A day it happened to me was over 50*f outside and when it's 20* out it doesn't do that etc. It was obviously a bs answer and I'm frustrated in this car already and I haven't even made the first payment on it yet.

Also I noticed condisation in my rear light. And apparently that is normal also. Jeep has an advanced ventilation system and that's why it's like that. Not completely sold on that explanation either but I could be wrong on that.
 

·
Registered
Joined
·
246 Posts
I found that it has happened with me as well.

Also a number of times I start the car and the defroster comes on rather than the automatic air settings.

seems like a lot of electrical issues with this car.

Sent from my SM-G965W using Tapatalk
 
1 - 19 of 19 Posts
Top