My Jeep Compass Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
398 Posts
Discussion Starter #1 (Edited)
Hey guys,

I noticed that I am hearing a irregular clicking noise from around the front wheel area on my 2018 TH. It almost sound like a bad u-joint but it seems to be a bit too irregular to be a bad u joint (either wheel or drive shaft). It is not in sycn with engine speed, transmission gear, 4wd lock, traction control, breaking or AC.

When I first realized the noise as it was almost coming from inside of the driver side A/C vent or behind the left side of the dash. But up on further inspection, I realized it is coming from the front wheel area. The noise becomes noticeable around 35mph, it gets louder at around 60mpg and than disappears. Do anyone else has this and do you have any idea what this might be?

I have read a very similar description for a Jeep GC, they eventually traced the noise to the front muffler that had a lose bolt. In my case the sound also resembles the ticking of a muffler but I couldt find any lose bolts.
 

·
Registered
Joined
·
398 Posts
Discussion Starter #3
Piece of loose plastic or trim slapping a part of the body somewhere in the front when it catches the wind just right?
I checked those, but everything seems to be in place and tight. The noise is also more "metallic", that is why it reminds me of a bad ujoint or CV. But the noise is so irregular that I cant see how a UJ or CV can make that noise. It only increases with wheel speed and nothing else. Its also not always there, it comes and goes on its own.

I will try to get a good video of it, If I can I will post it hear.

If I cant figure out what it is, I will take the car to the dealer on Tuesday.
 

·
Registered
Joined
·
965 Posts
Does it sound the same on different types/ages of asphalt? Just trying to think of how a rock or nail in the tread could be ruled out. You'd think it would make the noise all the time if it where a rock but maybe not if some of your roads are "softer" than others (just shooting in the dark)
 

·
Registered
Joined
·
398 Posts
Discussion Starter #5 (Edited)
Does it sound the same on different types/ages of asphalt? Just trying to think of how a rock or nail in the tread could be ruled out. You'd think it would make the noise all the time if it where a rock but maybe not if some of your roads are "softer" than others (just shooting in the dark)
Okay I think fixed the problem and it is so stupid. It’s basically the lamiated label tag with the QR code that FCA stick on all their freaking parts. The label was wrapped around the top of the suspension spring. It is a ~12 inch ribbon like tag that has one sticky side, it was looped around the suspension spring and then the two sides were sticked to eack other. It some how got partially detached from it and basically formed a lariat around the spring. Basically with speeds above 35mph, the wind around the tire was causing the label to whip around and hit the suspension spring. Higher the speed more it whiped around and so more noise. This was the cause of the random clicking noise. I assume it was randomly going away as the label got stuck and stopped moving or when it was pushed aside by the wind. I removed the label and the noise went away.

For future reference, if anybody gets this random noise, check these lables. They are not visible from the outside as they are sticked to the very top of the spring, but you can feel them with your hand and peal it off. Both driver and passenger side springs have these.
 
1 - 5 of 5 Posts
Top