My Jeep Compass Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2018 compass latitude that I bought from the showroom in June 2018 with 56miles on it. Everything was perfect - no issues till yesterday. ESS light came on solid and during driving suddenly the vehicle jumped to limp mode, all my warning lamps lit up, the wipers failed and headlights. We got it home and I started it again after letting it sit. All the lights were still on, every system came through with warnings. when I went to shut it down, the car was stuck in park but it didnt see that it was in park and I had to pull the battery cables to shut it off. With the batteries connected all the brake lights are also on, so its sitting in the driveway immobile and with no batteries connected.

My dealership is out an entire month on appointments so I searched online and saw that Aux battery is normal cause. So I tested the battery and it showed 10.5 at posts, so I replaced the Aux with one from the dealership parts department. After install of aux battery (Main battery bench tested good with 100% charge) ESS is working again but everything else is still broken and I still have to pull battery to shut off... The car has 65k miles on it and I dont see how the ESS and Aux system can completely wreak havoc on my car and its electrical systems...

When the batteries are pulled I know the IBS needs to recalibrate but am unsure if this is the cause of the issue and cant recalibrate if I have to pull the battery cables to get car to turn off as the recommended calibration is 1 start and atleast 4 hours off-time WITH BATTERY CONNECTED.

If I could get the dealership to work on it I would, but I cant be without my car for a whole month or more...
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top