My Jeep Compass Forum banner
1 - 6 of 6 Posts

·
Registered
Compass Limited 1.3 DDCT
Joined
·
4 Posts
Discussion Starter · #1 · (Edited)
Hello,
I picked up yesterday my jeep compass limited with led headlights.
I should have checked it at dealership, but while travelling at night going home, i noticed that both high beams were off. No error. Instrument cluster's notifications suggested that signaling and auto high beam were working when pressed.
I called the dealership and they haven't heard anything like that before.
I'll take the car to them in order to search for possible cause..
Does anyone had same issue?
Thanks!
Wheel Tire Car Vehicle Automotive lighting
 

·
Registered
Compass Trailhawk 4Xe
Joined
·
80 Posts
Hello!

Not good.


Could it be the auto high-beam malfuntioning?
I had noticed the high-beams not coming on, or delayed too much in certain conditions, on mine I've deactivated them.
 

·
Registered
Compass Limited 1.3 DDCT
Joined
·
4 Posts
Discussion Starter · #3 ·
Hello, i tested both activated and deactivated the auto high beam feature but no luck. Also, on my 2 hour highway trip and 30 min in the city, start/stop was "not ready". I asked them if all of them indicate battery issue, but they told me that headlights would work in any battery status.
Anyway i have an appointment on Friday and i hope for an easy fix.
Thank you for your answer!
 

·
Registered
Compass Limited 1.3 DDCT
Joined
·
4 Posts
Discussion Starter · #5 ·
Lights switch is on auto.
Auto high beams tested on and off with no luck.
I hoped for a bad setting solution, but they don't come on even when signalling .
Instrument cluster shows blue headlight indication like it works fine.
 

·
Registered
Compass Limited 1.3 DDCT
Joined
·
4 Posts
Discussion Starter · #6 ·
Went to the dealer today. They said that factory had zero appearances of this fault. They tried several things, at last they flashed the ECU and everything working properly. There was no logical explanation.
Thank you all
 
1 - 6 of 6 Posts
Top