My Jeep Compass Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Guys,

I have 2007 Jeep Compass - sports model. One day (after one year since I bought); I opened the door using remote key and then try to start the jeep, wouldn’t start. It does not make any cranking noise. It was acting as if the key is not recognized. The remote button on the key also wouldn’t work (less than a minute back I have opened the door using same key!). I also tried to start using backup key; same result. I called the towing company and they tried to boost the battery; did not help. I have to get it towed to dealer. The dealer fixed the problem and told me that the problem is with key. They claim that they reset the key to get it working. But amazing part is the backup key which I did not give to dealer also started working. I tried to confront the dealer with this question. He was elusive and told me that mechanic is too busy to discuss this.
I faced with same problem again after another year. My question is that is there is any design flaw with the compass which Chrysler is not accepting. For me it appears to be design or mechanical problem. Does anyone know of recall for problem of this nature?

Thanks
 

·
Registered
Joined
·
222 Posts
first off which dealer did you go to in toronto? and i have had a odd thing happen with my key all of a sudden when i lock it the horn wont beep or when i unlock it my lights dont come on but other times it does. i was thinking there is something wrong somewhere.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3 (Edited)
Thanks Zackman for the reply. I go to dealer in Mississauga area (Cooksville). I have been to another dealer when it happened second time. The second dealer noted following statement in the invoice

Cause: Pushed in to shop, scanned, found SKIM module lost communication unplugged skim module, reset module, tested and started

Correction: Replaced SKIM module, programmed module and keys while scan tool connected. Found PCM flash, updated PCM

I am not sure what it meant (I did not go to pick up the jeep after repairs)

After my posting yesterday, I browsed for similar kind of problem on the forum, found few postings. Most of the postings were referring to battery connections. The postings say the problem was resolved by disconnecting the connectors from the battery and putting them back. I wonder how difficult to do this? Does it involved any tool or is it easy enough to pull using hands.
 

·
Premium Member
Joined
·
849 Posts
I would escalate to the regional manager in this kind of case.......

My 2 cents....
 

·
Registered
Joined
·
1,897 Posts
PCM, they updated the computer software and maybe other modules as well. Sound also like the SKIM module may have been faulty so they replace it prior to the software upgrade. I expect this was under warranty if not. Call Chrysler and complain.
 
1 - 5 of 5 Posts
Top