My Jeep Compass Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
I’m having some issues with the navi on my new compass. It can’t seem to get my current location right. Every time I turn on the car it can be off anywhere from 10-15 miles on my current position.

I’ve checked Uconnect website for firmware updates and it lists my vehicle as current so nothing to download.

I’ve called Uconnect support and the operator couldn’t offer any fix remotely. Suggested doing a hard reset (unplugging the vehicle battery) or going to the dealer to have them reset the navi.

It’s not a critical issue so I haven’t put it on my priority todo list, I’ll probably disconnect the battery before going to the dealer since I prefer to fix things myself.

Anyone else have a similar experience with the navi? What fixed it for you? :glasses:
 

·
Registered
Joined
·
927 Posts
Do we even have any other members here who have navigation on their new compass? :think:

Doesn't seem like very many of them are coming with nav, kindof a top of the top tier options. I mean, even our "Limited" with the 8.4 uconnect does not have nav :dunno:

Suffice to say, I can't be of any help cuz I don't have that option. All I can say is using google maps through Android Auto works pretty great... :rolleyes:
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
Oh I definitely prefer to use my phone since I believe it’s more accurate anyway. However having paid for something I’d just like for it to work wink:

Other than the nav issue, Uconnect and the 8.4 touch screen have been great. Easy to read, bright and responsive touch screen controls with fast transitions moving between apps. Just nav is useless right now.

And to be honest I didn’t even buy the car wanting nav, it just happened to be on the vehicle we purchased.
 

·
Registered
Joined
·
44 Posts
Hi,

I got the navi in my 2018 Latitude and Ive used it maybe 3 or 4 times and have not had that problem at all. Do you happen to live any where where service may be a bit spotty, because that seems to happen with nav on my phone at random times.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #5
I live in and work around Northern California, between San Francisco and San Jose. I’m surrounded by tech companies including Google, Apple and Facebook. If anyone should have solid GPS it’s me lol.
 

·
Registered
Joined
·
436 Posts
I’m having some issues with the navi on my new compass. It can’t seem to get my current location right. Every time I turn on the car it can be off anywhere from 10-15 miles on my current position.

I’ve checked Uconnect website for firmware updates and it lists my vehicle as current so nothing to download.

I’ve called Uconnect support and the operator couldn’t offer any fix remotely. Suggested doing a hard reset (unplugging the vehicle battery) or going to the dealer to have them reset the navi.

It’s not a critical issue so I haven’t put it on my priority todo list, I’ll probably disconnect the battery before going to the dealer since I prefer to fix things myself.

Anyone else have a similar experience with the navi? What fixed it for you? :glasses:
Hi Sofa88,

Sorry to hear about this! If you end up deciding to visit your local dealership for further diagnosis I'd be happy to offer assistance if needed. Just send us a PM with your VIN and let me know.

Andrea
Jeep Social Care Specialist
 

·
Registered
Joined
·
22 Posts
Discussion Starter #7
Thank you for that Andrea! I may take you up on that if the battery disconnect doesn’t resolve it. I’ll probably try the hard reset option this weekend. Great to have a Jeep rep on the forum smile:
 

·
Registered
Joined
·
22 Posts
Discussion Starter #8
4/30 UPDATE** Navi accuracy issues

UPDATE: We’ll I finally got off my butt and scheduled to have a Jeep dealer take a look at my problem. They determined pretty quickly that I would need to have my radio unit replaced to resolve the nav issue. They stated that this would be covered under warranty and replaced with no cost to me, GREAT! Well the not so great part is my service appointment was 3/28 and here I am 4/30 and no new radio in sight.

I texted my service advisor (nice guy) to get an update on 4/3 and no ETA according to him. Text again on 4/13 and this time no reply back. Texted again just yesterday and now I feel like I’m just being ignored. Guess it’s time to message the Jeep Cares folks.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #9
UPDATE!

Well after getting the Jeep Cares folks involved it seems they didn’t have much influence in my situation. I was assigned a case number, was told it was escalated and given the contact info to the person handling my case. She’d call saying she tried to call the dealer’s service department and left a message but they did not return her call. I received three calls like this from the case worker, and each time I tried to call her back her voicemail said she was out of the office! The final voicemail from her was basically “here’s our contact info if you have any other questions” with the issue unresolved and no updates provided. Basically they’d given up since the service department was not calling them back! SERIOUSLY!?

So after 4/30 I let about another month go by, but my patience exhausted. I made some time in my schedule and walked into the service department to speak with my service advisor directly. He pulls up my work order and calls parts department to see if the radio/nav unit had arrived, they said ETA is a few days away and that it was on BACKORDER!!! Why couldn’t someone just tell me this the first time!?

Finally I arrange to return to the dealer at 7:00AM the day the part is expected to arrive to get it done and installed. I get a call back at 10:30AM the same day letting me know my vehicle is done and ready for pick-up.

Over two months!!! GAAAAH!!!! I’ve never had a service experience as bad as this. Just glad it’s done and over with.
 
1 - 9 of 9 Posts
Top