My Jeep Compass Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
927 Posts
Mine has given a little trouble that way once or twice, shutting it off for a good 5 minutes and restarting it has always taken care of the issue the two times it has ever happened.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
I've tried different cords, phones and nothing. I can play music through the aux cord, but that's it.
 

·
Registered
Joined
·
927 Posts
Google for uconnect reset maybe, I believe it involves holding the two buttons in the volume and tuner knobs for ~30 seconds with the ignition in aux. mode or something like that. Pretty sure the USB ports have no fuse of their own, they as listed on the same 20 amp fuse as the radio so if the radio works it probably just needs a reset.
 

·
Super Moderator
Joined
·
113 Posts
Google for uconnect reset maybe, I believe it involves holding the two buttons in the volume and tuner knobs for ~30 seconds with the ignition in aux. mode or something like that...
Twice I have had the rear USB port in my 2019 Compass stop working. The first time, after finding the above post, I Googled and found various reset instructions, I tried several of the methods and eventually stumbled upon something that worked (but I wasn't sure exactly what).

Today the port stopped working again and I found that the following procedure worked to restore my USB port:

1. Put your vehicle into accessories mode (push start button once without having your foot on the brake)

2. Hold down the Green Phone and Voice Recognition buttons for 30 seconds (push the buttons immediately after pushing the start button, before the Uconnect system has a chance to fully boot).

3. Let go of the two buttons.

4. Turn vehicle off and wait for the Uconnect screen to go black.

5. Open driver’s side door for thirty seconds.

6. Close driver’s side door.

7. Restart vehicle.

8. Let the uConnect system to load up and see if concern is still present.
 
1 - 7 of 7 Posts
Top