My Jeep Compass Forum banner

41 - 60 of 63 Posts

·
Registered
Joined
·
10 Posts
From time to time, the sync goes off, and the passenger side sets itself to 79 degrees. It seems totally random, because I can't seem to pinpoint the timing, or if something is triggering it. It is definitely not being changed via the controls. Anyone else having this happen? I called the dealer and they said they have not had any issues with this...
Same here...

About 95% of the time when I get in the Jeep and start it up, the USB flash drive starts playing the MP3 right where it left off automatically. About 5% of the time it goes straight to radio...
Same here..
 

·
Registered
Joined
·
147 Posts
Mine randomly resets, auto turns off and temp goes back to 72°, I've noticed it seems to do it most often when I'm sitting at work in my car with it off and windows down and I quickly turn it on (not engine running) to raise the windows and shut it off. When I get back to it after work it's reset, not everytime but that's been my experience. Maybe I need to let the radio fully boot up before I turn it back off.

Sent from my Pixel 2 using Tapatalk
 

·
Registered
Joined
·
13 Posts
Yes, mine is a 2018 TH and every few days the system remains OFF despite the setting previously. When turned on, it defaults to an unsynced 22degrees C for each side. There apparently is no software fix for it yet. I've also had a number of other issues with the system, and it's getting pretty frustrating.
 

·
Registered
Joined
·
0 Posts
Hi! I just bought a 2018 Jeep Compass latitude and this same problem is happening with me. Every 20 or so starts the fan turns all the way up and the both drivers side and passenger side goes to 75 and 79 degrees respectively. Half the time I reset the climate to my preference (a/c on, 65 on both sides) and it adjusts ASAP but today the climate control wouldn’t adjust even though the controls were set to my preference. The ac wouldn’t come on until I reached 60 mph. Almost like the climate control system wouldn’t register the changes until a certain mph was reached. So frustrating. I’m calling the dealership tomorrow
 

·
Registered
Joined
·
136 Posts
Yes, mine is a 2018 TH and every few days the system remains OFF despite the setting previously. When turned on, it defaults to an unsynced 22degrees C for each side. There apparently is no software fix for it yet. I've also had a number of other issues with the system, and it's getting pretty frustrating.
Well Uconnect is junk, and that's what happens when jeep demand that air-con be routed through the car stereo.

I feel for ya. 90% of my complaint with the new jeep is based on the faulty, half-baked touchscreen.
 

·
Registered
Joined
·
1 Posts
My wife's 2018 jeep compass north has the exact same issue.

Approximately 10-15 starts the climate control settings get lost.

Sync turns off, auto turns off. Can't quite understand why this would happen on such an infrequent basis.

We're likely going to to take it to the dealership and probably reference this forum so they don't think we're crazy.

Hope this issue gets sorted out and if it is a software issue with Uconnect which is kind of how things sound that Jeep issue a update to fix this.

Gotta love having a brand new vehicle with issues right outta the gate.
 

·
Registered
Joined
·
1 Posts
Same issue, 2018 Compass TrailHawk, purchased in May, 2-3 times a week the climate controls default to both side Hi or Lo and vent to floor after a restart. No pattern that I can see.
 

·
Registered
Joined
·
87 Posts
My automatic climate control is also acting weird twice at random.
2018 Limited

First incident:
When activating the front defroster and switching back to 'auto' -- 'Sync' turned itself off and temperature went down to 'LO'

Second incident:
After a morning start, the climate control is completely off. It was on 'auto' the night before

It seems like the touchscreen U connect is not getting along with the bottom climate control switches.
 

·
Registered
Joined
·
172 Posts
Now that it's getting cold out and I'm using the heater on a regular basis, you can add me to the list of climate control not staying synced. Despite sync being orange (on) in the climate control menu, my passenger climate setting is usually "Lo" while the driver side is set at a particular temperature such as 68.
 

·
Registered
Joined
·
434 Posts
Same issue, 2018 Compass TrailHawk, purchased in May, 2-3 times a week the climate controls default to both side Hi or Lo and vent to floor after a restart. No pattern that I can see.
My wife's 2018 jeep compass north has the exact same issue.
Approximately 10-15 starts the climate control settings get lost.
Sync turns off, auto turns off. Can't quite understand why this would happen on such an infrequent basis.
We're likely going to to take it to the dealership and probably reference this forum so they don't think we're crazy.
Hope this issue gets sorted out and if it is a software issue with Uconnect which is kind of how things sound that Jeep issue a update to fix this.
Gotta love having a brand new vehicle with issues right outta the gate.
My automatic climate control is also acting weird twice at random.
2018 Limited
First incident:
When activating the front defroster and switching back to 'auto' -- 'Sync' turned itself off and temperature went down to 'LO'
Second incident:
After a morning start, the climate control is completely off. It was on 'auto' the night before
It seems like the touchscreen U connect is not getting along with the bottom climate control switches.
Now that it's getting cold out and I'm using the heater on a regular basis, you can add me to the list of climate control not staying synced. Despite sync being orange (on) in the climate control menu, my passenger climate setting is usually "Lo" while the driver side is set at a particular temperature such as 68.


Hello everyone,
We regret to hear that you are experiencing these concerns with your climate controls. We understand how this could be frustrating and would like to offer our assistance should any of you choose to visit the dealer to have this looked into further. If this is something that interests you, please send our team a private message with additional details.
Julie
Jeep Social Care Specialist
 

·
Registered
Joined
·
72 Posts
My dealer (in the U.K.) is still telling me that there is no fix for this.

They have had the car in twice and recreated the problem but just say they are waiting for a fix from Jeep.
 

·
Registered
Joined
·
434 Posts
My dealer (in the U.K.) is still telling me that there is no fix for this.

They have had the car in twice and recreated the problem but just say they are waiting for a fix from Jeep.
Hey rriggs,

Because of your location, customer care in the UK can assist you best. You can find details on how to contact them here:
https://www.jeep.co.uk/mopar/jeep-customer-service

Jennifer
Jeep Social Care Specialist
 

·
Registered
Joined
·
45 Posts
There is a HVAC Software Update for this issues already out since early October and it covers Compass MP and M1 off all regions (NAFTA, LATAM and EMEA). TSB # is 24-011-18.

Unfortunately, RHD Models M6 are not covered.
 

·
Registered
Joined
·
4 Posts
I am having the same issue and I am bringing her in to the dealership on Tuesday! Hopefully they find and fix the issue!
 

·
Registered
Joined
·
434 Posts
I am having the same issue and I am bringing her in to the dealership on Tuesday! Hopefully they find and fix the issue!
HI jio808,

I am sorry to hear that you have a concern with your Jeep. If you are in need of additional assistance while at the dealer, please let us know.

Darlene
Jeep Social Care Specialist
 

·
Registered
Joined
·
87 Posts
Been there done that. Already had the climate control module replaced. It was still doing the same after the module replacement until I traded it in last week.
 

·
Registered
Joined
·
3 Posts
Only issue iv seen on them with hvac issues (work as a service advisor) is hvac forgetting the settings you put, but that was an hvac update and came out in December.
 

·
Registered
Joined
·
32 Posts
I am experiencing this same issue. Noticed it today. Got out of my car with the climate set to 76* and came back a few hours and it set itself to HI on the passanger side and LO on the driver side.
 
41 - 60 of 63 Posts
Top