My Jeep Compass Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi all im new here but not new to cars or stereo installs.
I put a new stereo in my wifes 07 jeep compass and afterwards the HVAC lights quit working. I know i wired everything right and plugged everything back in has anyone else had this problem? If so what did you do to fix it? If not any ideas?

Thanks all
Robert
 

·
Registered
Joined
·
1,897 Posts
I saw your entry in the new users forum and came down to see what you had posted.

Well to be truthful I read this ages ago. But would ask what do you me specifically (HVAC typically is High Voltage AC powered whatever) and that does not apply to auto lights.

Maybe if you backup and indicate clearly what lights are not working and condition tried help may pop up or at least suggestions.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Sorry by HVAC i mean heat vent and ac lights lol sorry for the confusion
Basically the lights around the vent and heat knobs stopped working
 

·
Registered
Joined
·
1,897 Posts
Ok, now we understand. Well I have not had my Radio out. However a beer says you have accidentally pulled the power plug out or partially which connects to the circuit board there.

Pull the Radio and get a small LED flash light an look around. Those which appear there and in place could stand a gentle push to ensure they're fully seated in.

The stereo could have hooked a cable as you were inserting it to also pull the connector from the socket.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
I just haven't taken the time to tear the dash apart again its such a pain to take apart one day ill have to though and check all the plugs Im 98% sure i plugged everything back in but ya never know
Thanks for the response
 

·
Registered
Joined
·
1,897 Posts
tripplec So uh where can i send that beer? lol i just missed one when i was putting everything back together
Well I think you'll have to have it for me. I am likely a tad too far away. So Cheers and bottoms up, so to speak and I am glad you're seeing the light.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
Will do Thanks for the feed back again
I still cant believe i missed that plug i ALWAYS double and triple check things
 

·
Registered
Joined
·
1,897 Posts
Well that center console is real tricky. I did not have it out myself but after 4 return yes return after having had my instrument cluster replace. Murphy was there.

After I drove away and picked up steak and fish for upcoming dinners.
- turn vent on, no air from vents only floor (turned and went back to dealer)
- service that and off I went. Air was cooler then it should be. A/C was on but not the light nor would it come on (turned around and back to dealer)
- service it again and off I went. All lights on A/C, recirculate, rear heater and toggled. Off I went and turned out A/C would not turn off, light eventually would not come back on but A/C still on. Popped hood and verify the compressor was indeed running. Back to dealer (PS I am still smiling and laughing inside a bit) Good thing I was not ticked and had some humour
- the tech looks at me as I way him over, stopped going to the service desk before this. Again he pulls the cover and the other tech is wondering what is going on. (he keeps borrowing the prying tool from him. I till him you had better pull and reseat the plug completely. I can't see what he is doing but looked like did and all is working this time. Thank god I did not have to make multiply service visit over the week. My wife would not believe me and would wonder what I did nor didn't do with the A/C.

So how was your friday?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #10
That sounds like a bad design on jeeps part too me I dont have any problems with subarus only american cars lol
 
1 - 10 of 10 Posts
Top