My Jeep Compass Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello All! Bought my first Jeep ever last week. Drove it about 300 miles, and noticed clicking/snapping noise in the front. Took it back to the dealership and it needs a CV Axle! It is a 2018 Compass Latitude with 48k miles. Is this a common issue? Dropped it off to get fixed under warranty today, hopefully won't need it more then a day!
 

·
Moderator
Joined
·
962 Posts
Welcome!

I haven't gotten to those miles yet. The earliest of the 2nd Generation Compasses may be getting there. I hope your problem isn't a harbinger. :(
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Welcome!

I haven't gotten to those miles yet. The earliest of the 2nd Generation Compasses may be getting there. I hope your problem isn't a harbinger. :(
I will post the outcome of this! Positive thoughts, and stay safe!
 

·
Registered
Joined
·
109 Posts
As them if the CV boot was loose or damaged....getting dirt in the CV joint can damage them.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Just got it back from Jeep dealership, had to reprogram drive train control module. So far I haven't heard it yet...fingers crossed!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
still having the same issue. Was sent to another Jeep dealership, which they said needs new brakes and rotors which is causing the noise. Had that done....still have the same problem! Also, since the 1st dealership did an update, my backup camera has stopped working, just a black screen!
Really bummed my 1st Jeep experience is turning into a nightmare!!
 

·
Registered
Joined
·
13 Posts
Well, I’ve had many problems with my ‘18 Trailhawk. Not that particular one though. The quality has been quite disappointing.
 
1 - 9 of 9 Posts
Top