My Jeep Compass Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello I am new to the forum, I have a 2007 Jeep Compass Limited and have owned for almost 4 years with no problems at all except the crappy tires you get on the car. At around 60k miles the MIL came on and it would stay on for 2 days and go off for 3 or 4 days and come on again and it would do it for about 2 weeks, it went off finally and we had the code checked and it wasn't a "problem" code.....about 4 days ago it came on again and has stayed on. I have experienced some hiccups when accelerating occasionally but not all the time and the start up can be kind of rough from time to time..... I am thinking maybe it needs a tune up..... any suggestions or anyone having a similar problem? :(
 

·
Premium Member
Joined
·
1,362 Posts
Hello and welcome to the forum, glad to have you join us! Sorry to hear about your problem. Since the light came back on, have you had it checked again and was it checked by the dealer last time? I know some of those auto parts scanners aren't the greatest and even worse if the operator doesn't know what they're doing lol, but something tells me there has to be a stored code in there. If you can find out what it is, we can help interpret it for you but good luck, be sure to keep us posted and I hope you enjoy the site! :)

- Cherokee
 

·
Registered
Joined
·
205 Posts
If you ever have to change your tires may I recommend the Michelin Hydroedge. When I got rid of the factory installed goodyear SRAs I installed the Michelins. These are the best tires I ever owned. They are quiet, has great traction and they look good on the car. I am very happy with the performance and its longevity. The goodyears only lasted about 40k miles and now I already have 128k miles on my 07 compass and the tires still look great.
 
1 - 3 of 3 Posts
Top