My Jeep Compass Forum banner

Newer 2017 Compass with U connect screen delamination No Parts to fix

3695 Views 2 Replies 3 Participants Last post by  DMose
I have a new model 2017 Compass and the U connect screen started to peel from the inside at 2 years. It’s not 3 years old yet and 20,000 miles. I took it in for the crazy start stop battery that never worked and killed my main battery and they said the U connect needs to be replaced. I have waited 4 weeks for the part. Yesterday on a long drive the screen went craze. It’s 95° out in Florida and the heated seats and wheel come on. The AC rapids from high to low and the navigation is flashing through fast motion. I’m now told this is a big problem with Uconnect. They are not a Jeep Chrysler product and until U connect ships parts we are just out of luck. I am lucky to be under warranty. I have a feeling it is the Florida heat. Has anyone had luck in protecting their U connect screen from the high temperature in the car? Anyone else having this problem?
1 - 3 of 3 Posts
In Texas. Same problem. I called multiple jeep dealers and service all told me the same thing. It is the heat causing the bubble inside (delamination).Since I'm outside warranty then it is completely out of pocket. I have called multiple car stereo places too. They told me same thing. Seen a lot of same problems with the Uconnect. One service guy at Jeep told me if it were him, he would not bother replacing it through the dealer because you would end up with the same POS. He would go with an aftermarket screen.
Mine started bubbling earlier on. Bought my jeep brand new. Was too lazy to make an appointment with dealer and now it is not under warranty. Lesson learned.
Same vehicle, same state, same problem. Mine has starting the peeling on the inside and it’s been going crazy for 3 weeks. They told me Friday that’s my radio is fried and it’s $1000 to replace it. Start stop quit working a year ago and the battery for that was just replaced and it’s still not working.
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.