My Jeep Compass Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Everytime I've taken the Car to the dealers for something or other I've had the Oil and Filter changed at the same time. And each time I come away from the Dealership either they've forgotten to or something else...Cancel the Indicator. I've followed the Prompts in the Manual ( ignition turned on without starting, press down on gas peddle 3 times within 10 snd's , turn ignition off then start)..Could the Sensor be bummed up ??:dunno: I've gotten to the place ignoring the chim going off and the Oil Change flashing... I still pull the dipstick and check the level and color.....Thanks
 

·
Registered
Joined
·
1,897 Posts
It must go out at least if its on. I turn on the ignition myself and wait until all the lights turn off the come on for a few seconds. A few don't go off for various reasons. Then I do the cycle slowly but within 10 secs. If I think I took too long I turn off the the ignition wait the do it all again. Personally I have never seen the light come on since I change my oil by 5000km which it already quit long. I don't believe in those extra long oil changes especially if you're keeping the vehicle. If you're paying the dealer to do the changes then take it back and have them reset it and/or check why its not working.
 

·
Premium Member
Joined
·
1,362 Posts
Never really thought about it that way, but tripplec could be right (the dealer always re-sets mine so I haven't had to worry about it), but try turning the ignition on as described in your manual, wait for the initial bulb check to finish, and then press the gas and follow the steps.

- Cherokee
 
1 - 3 of 3 Posts
Top