My Jeep Compass Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey all! Have had my 2012 Jeep Compass North since last May. This past November I began experiencing horrible fuel mileage. At the same time I was dealing with the brakes squealing as I was in reverse. Took this issue to the dealer and they replaced the pads because they had "metal" deposits and were under warranty. I explained the mileage issue and they said probably brake related. I let it go for a bit to see if there was any improvement. Sadly none. I called the dealer and they "checked it out". No codes were coming up so there was nothing that they could do. Currently I get 5km/l. My last fill up was 49 litres and got 250 km. I pretty well only do city driving. This car has less that 7000 km on it. Any one have any issues like this or any suggestions?
 

·
Registered
Joined
·
1,897 Posts
Nope, not that bad. Clearly something is wrong and at that low millage it must very rich running with implies very sooty exhaust. It should be black as coal in the tail pipe. Unless there is a leak somewhere.

Unless the brakes dragging a lot it will not affect gas millage. Calipers make a slight contact normally. I sounds like you need to take to another dealer rep or take it to another dealer entirely. If you're not getting anywhere call Jeep customer service and that them direct the dealer on what to check, service or replace. They should be able to pin point that problem.

Of course we assume there is no fuel leak. The transmission is in D and not 1st gear in tiptronic mode where the engine will over rev at normal speed since its not shifting.
 

·
Super Moderator
Joined
·
534 Posts
Hey all! Have had my 2012 Jeep Compass North since last May. This past November I began experiencing horrible fuel mileage. At the same time I was dealing with the brakes squealing as I was in reverse. Took this issue to the dealer and they replaced the pads because they had "metal" deposits and were under warranty. I explained the mileage issue and they said probably brake related. I let it go for a bit to see if there was any improvement. Sadly none. I called the dealer and they "checked it out". No codes were coming up so there was nothing that they could do. Currently I get 5km/l. My last fill up was 49 litres and got 250 km. I pretty well only do city driving. This car has less that 7000 km on it. Any one have any issues like this or any suggestions?
I"M getting terrible mileage, however I seem to only get it in the winter, now I know vehicles go down in mileage in the winter due to gas cold weather ect, however mine this winter has gotten reall ybad, now I do almost 100% city driving and short drives here and there, and use the remote start but my last tank was 270kms and avg's 15.2l per 100 kms, i'm thinking something might be up, however in the summer the mileage is almost normal.
 
1 - 3 of 3 Posts
Top