My Jeep Compass Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey guys, fairly new to the forum. I have had my 2011 Jeep Compass Trail rated since October of 2016, bought it used with 55k on it, I am now at 69k and have a few times now experienced the "whine" from the CVT as it gets hot and begins to slip. Yesterday I set out on a road trip with my wife, and about 100 miles in, the CVT overtemp light came on (the gear with the thermometer in the middle). I was literally in the middle of nowhere (Arbuckle Ca.... nothing but orchards) so I pulled over and let it cool down for about 20 minutes, light went off and we set off again. only about 10 minutes up the road, the light came on again and the trans was slipping badly. I pulled off the next exit and got out my phone and started checking forums for answers. I saw people repeatedly talking about cooling, cooling, cooling. A little about me, I am a certified mechanic and I work on diesel mowing equipment for a living.... we have heat issues a lot due to plugged radiators.... so I thought to myself, " I wonder if my radiator is plugged up and blocking the cooler from breathing?". I popped the hood and tried to see daylight through the fins...NADA... so i told me wife keep her eye out , we needed to find a hose or a car wash with a pressure washer... a few hundred feet down the road, we spotted a well tank at the edge of an orchard and it had a garden hose attached. So i pulled up, left the car running and sprayed water through the radiator to clean it out and i could hear the electric fans pulling it through... I knelt down and hit the radiator from under the valance also, I sprayed it out for a good 10 minutes. The light went off from the trans immediately, my car itself cooled down from the midway point on the temp gauge to about 1/4 the way, and the whine went away instantly. I got back in the car and got back on the road hesitantly. I increased the speed over the next 10 miles... no issues. So we continued for 400 more miles yesterday up into the mountains without a hitch, engine temp never went up, and neither did the noise of the transmission. And I was not easy on it, we climbed to 6200 ft yesterday up in the mountains and back and never another issue.

So if you start getting the whining, pull out your garden hose and clean out your radiator so it can properly cool the transmission fluid. grin:
 

·
Registered
Joined
·
50 Posts
Grate find.
I say the radiator is one of the most over looked items on a vehicle, it should be checked every oil change and cleaned.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thanks, I had been getting the whine almost every day on the way home from work (45 minute commute) and I thought it was just because I drive it hard, but I have been driving it since Saturday and no reoccurance of the whining. The other thing I thought of was that on Saturday, I did get an automated carwash, I wonder if the spray wax may have been what plugged up the radiator a bit. It was pretty bad though, we almost cancelled our trip because it overheated 3 times in about 10 miles, I would stop, let it cool, and start going again and the light would come back on after a few miles. It is obviously a heat exchange problem, I wonder if a larger cooler would help, other than that, a radiator cleaning and cooler flush should help tremendously.
 

·
Registered
Joined
·
162 Posts
Great tip! You'd think the radiator would be cleaned more often, but I'm guilty of not checking it no matter what car I drive.
 

·
Registered
Joined
·
1 Posts
I know this is a old post but I have a 2008 jeep Compass with the same issue of the transmission temperature light coming on. My question to you is did cleaning out your radiator with a garden hose completely fix the issue or did you have to have something else done to it.
 

·
Registered
Joined
·
831 Posts
@Compass 08 That guy hasn't logged in for over two years now so I doubt you will get a reply from him. Its practically free to try so definitely give it a go, I would recommend if you don't have a pressure washer maybe go to your nearest self-serve car wash where you can use a pressure washer for a few quarters and that would probably work better than a garden hose. Be somewhat careful too though pressure washers can do damage to paint when you hold them too close so I'd not hold one too close to a soft old radiator either, but if you just spray through the grill as best you can it should be fine.

It would also be good to double check that your radiator ran is working. I don't know if there is any way to check that the transmission has fluid in it but check it if you can (if its not sealed) and if its never been flushed or had a transmission filter change I would recommend that as well.

I don't personally know much about the CVTs, good chance its sealed with no dipstick but it shouldn't cost that much to have the fluid flushed and the filter changed, spray out the radiator, and then go from there (if it were mine thats what I'd do).
 
1 - 7 of 7 Posts
Top