My Jeep Compass Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Greetings fellow owners. Just bought a 2017 Compass Limited with 45K miles on it. Very nice Jeep. We have 2 Renegades in the family so we know these Jeeps well. One issue I do not have with the Renegades but have on the Compass is a shudder that always happens when starting from a stop or going around a corner under light acceleration around 18mph that can be felt in the steering wheel and seat. I also noticed the same shudder on the highway when climbing hills in PA around 70mph, both seem to be when the engine is under load (accelerating). I had the Compass at Jeep last week to address the shudder at 18mph and also address the drone vibration at 37mph. The drone was fixed via TSB software update and they claim to have updated 2 other s/w programs for the drivetrain, but neither has helped the shudders. I was thinking maybe the shudders can be an engine miss (plugs or ignition coil) but I have no CEL or codes, and outside of those 2 situations, the Compass drives smooth. I did notice on the Carfax that an ignition coil had been replaced 2K miles ago, don't know why. Can it be ignition coils or plugs? Or is there another cause that has an identified fix?

Appreciate any help!

Keith in NJ
 

·
Moderator
Joined
·
1,039 Posts
Welcome, Keith! Glad you found us. Indeed the drone can be fixed as you discovered. Actually the software moves the drone to higher speeds where it's not so noticeable.

I'm not sure I understand about the shudder. A misfire under load is a classic symptom of a bad coil. Based on your Carfax report, maybe that's what the previous owner tried. Is your Compass the first of the 2nd generation Compasses or the last of the 1st generation? If its the 1st generation, those plugs are only good for 30,000 miles. If you're at 45,000 maybe it's overdue. Simple DIY job on the 1st generation. I haven't had to do it on my 2nd generation.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
New body style, so 1st generation of 2nd generation? Maybe I'll just replace all coils and plugs and see of that helps. Basically at 18mph or when kicking down the trans to climb a hill on the highway around 70mph the wheel feels like it starts to shake and you can feel it on your seat/floor. Smooths out after 22mph or after leveling out on the highway. Seems to me more trans or torque converter? I'd think a bad coil or plug would throw a code?
 
1 - 3 of 3 Posts
Top