My Jeep Compass Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2012 Compass Latitude with 32000 miles

The other day I was driving on the highway for a good 45-60 minutes and going an average of 80mph. My car reached just below a 1/4 tank of gas and stopped accelerating. I felt the vehicle pull back as it was slowing down. I quickly pulled over and shut off the car. I tried to start it back up multiple times and it would start but the engine would shudder while running so I was afraid to put it in drive and simply got it towed. It was towed to my house and after sitting for about an hour I tried to start it. Started right up and drives fine. This is the SECOND time this has happened to me under the same exact circumstances (same driving distance, same MPH, same amount of gas)

After letting it sit for a few days, I drove it today to the gym. Drove fine, however I noticed the fuel was depleting at a rapid rate after starting the vehicle. I started it and it had just below a 1/4 tank like it did when the problem happened, however after driving it about 1.2 miles the gauge went down gas light came on. I filled it up, and it has not been depleting rapidly.

I am wondering if this could be a fuel issue? Whether it is the sensor? Pump? Gauge? I brought it to the dealership after the first time and they could not find any issues--they said they could not "recreate the problem". To recreate the problem they would need to be driving under the exact circumstances I was the first two times. I am at a loss. Anyone have a similar issue or know what this could be?
 
1 - 1 of 1 Posts
Top