My Jeep Compass Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,897 Posts
Discussion Starter #1
Well I've had plenty of trouble with my fog lights not coming on or a varying delay on coming on. Many times just turning them off and on triggers it correctly. However the dash indicator always comes on and is not indication of illumination out front. You can't run out while drive to see if they came on (at least I am not that athelitic). It has always boiled down to a fault in the TIPM which has been replace at least twice for that problem and was finally resolved a year ago. However, with my in dash temp not working properly it was replaced again (this is #4 or 5 at least now) to resolve decoding issues. I haven't used the fog lights much this winter and the last time it did not seem to light up the road any better. I checked today in found it would not come on despite over 6-10 varying combinations of on off but eventually did after a short drive going for gas. A hour later I when out and it wasn't working and on the 2nd on/off it came on after nearly 2 sec delay of pulling the switch.

The part is suppose to be under warranty for a year after changing. I will cross that bridge now and see. There is a lot of controls going through the complex module and in my opinion unnecessarily complex. Give the old relay fuse box of other vehicles and I can fix that myself. This is solid state for the most part and programmable. I must have at 10 service work order around this by now. No sooner I think I am getting ahead and eliminating problems what shouldn't happen happens.
 

·
Registered
Joined
·
98 Posts
Is there any way that something else is making this part fail prematurely? That maybe it's not the part that's the problem, but something linked to it?
 

·
Registered
Joined
·
1,897 Posts
Discussion Starter #3
Is there any way that something else is making this part fail prematurely? That maybe it's not the part that's the problem, but something linked to it?
Everytime the dealer trouble shoots it and tests the signals. The document that there is an internal failure. The original and 2 replacements had this fault affecting the fog lights. Two were replaced to address the dash temp not function (did not display the current temperature or did not updated for 4 hrs or more, oh the dash display was also replace twice for that reason as well).

If there is something else this time it would be huge surprise having been down that road way too many times. The symptoms are the same. I doubt the plugs into the TIPM from the Compass's electrical buss is the issue since the see the signal to turn it on but the power circuit did not activate. The dash light is separate.
 

·
Registered
Joined
·
222 Posts
Everytime the dealer trouble shoots it and tests the signals. The document that there is an internal failure. The original and 2 replacements had this fault affecting the fog lights. Two were replaced to address the dash temp not function (did not display the current temperature or did not updated for 4 hrs or more, oh the dash display was also replace twice for that reason as well).

If there is something else this time it would be huge surprise having been down that road way too many times. The symptoms are the same. I doubt the plugs into the TIPM from the Compass's electrical buss is the issue since the see the signal to turn it on but the power circuit did not activate. The dash light is separate.
this is the problem i have with my headlights! hopefully it will get fixed soon
 

·
Registered
Joined
·
1,897 Posts
Discussion Starter #5
this is the problem i have with my headlights! hopefully it will get fixed soon
The problem came back with another TIPM and they gave up replacing them. They did replace the Multifunction Switch stalk (left side of the steering column) a few weeks ago. So far its been ok. The part was around $70 plus labour but the dealer covered it even though the warranty is over..
 

·
Super Moderator
Joined
·
530 Posts
Ask the dealership about the "cabin control node" CCN if any problems come up again, now I have a 2012 (so it may be different) and had a ton of issues with what seemed to be the TIPM however it was not and they eventually narrowed down to the cabin control node, and after replacing that all my problems went away.

PM me if you want the scoop on what happened to my compass.
 

·
Registered
Joined
·
1,897 Posts
Discussion Starter #7
I have not heard of that unless its a 2012 specific item. Where is it located?
 

·
Premium Member
Joined
·
1,362 Posts
That's a new one on me as well, more info Tyler?

- Cherokee
 
1 - 8 of 8 Posts
Top