My Jeep Compass Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Here is the history of my 07 Jeep Compass that brought me to this point (sorry for the novel). I am getting desperate and do not want to replace my Jeep.

Had the catalytic converter replaced as well as the tie rods in April 2014. It also received a full set of all weather tires and I replaced the brake pads and rotors.

Within a day the cruise control would not consistently work, sometimes it would turn on sometimes it wouldn't. If it turned on it would stay on for a few miles then turn off and not turn back on.

October 2014 the Jeep makes the 1300 mile drive to Florida from Massachusetts.

Within a few months the traction light starts blinking as the vehicles goes into a turn, usually only to the right, and the car will not accelerate when stepping on the gas.

Then I start noticing a lot of shaking from the wheel at higher speeds, 55-80 mph, especially when exiting a highway onto an off ramp.

In the past two months the car would not start right away, I would have to turn the key in the ignition a couple times to get it going. Then it wouldn't start at all after driving it home after work.

Then the automatic door looks would switch on an off while driving, and then even when the car was off and the key no longer in the ignition or anywhere near the vehicle.

I had the battery replaced which had some corrosion/acid on the connections.

The car no longer stalls/dies but still doesn't start right away after an 8 hour work day. The door locks are still going on and off while driving and its happening so much its driving me crazy.

Anyone have any ideas?
 

·
Registered
Joined
·
403 Posts
Here is the history of my 07 Jeep Compass that brought me to this point (sorry for the novel). I am getting desperate and do not want to replace my Jeep.

Had the catalytic converter replaced as well as the tie rods in April 2014. It also received a full set of all weather tires and I replaced the brake pads and rotors.

Within a day the cruise control would not consistently work, sometimes it would turn on sometimes it wouldn't. If it turned on it would stay on for a few miles then turn off and not turn back on.

October 2014 the Jeep makes the 1300 mile drive to Florida from Massachusetts.

Within a few months the traction light starts blinking as the vehicles goes into a turn, usually only to the right, and the car will not accelerate when stepping on the gas.

Then I start noticing a lot of shaking from the wheel at higher speeds, 55-80 mph, especially when exiting a highway onto an off ramp.

In the past two months the car would not start right away, I would have to turn the key in the ignition a couple times to get it going. Then it wouldn't start at all after driving it home after work.

Then the automatic door looks would switch on an off while driving, and then even when the car was off and the key no longer in the ignition or anywhere near the vehicle.

I had the battery replaced which had some corrosion/acid on the connections.

The car no longer stalls/dies but still doesn't start right away after an 8 hour work day. The door locks are still going on and off while driving and its happening so much its driving me crazy.

Anyone have any ideas?
Hey KassandraLane,

I am sorry to hear about your recent experience with your Compass. Unfortunately, I could not locate any service bulletins that are applicable to your vehicle. I would advise you to have the vehicle formally diagnosed at an FCA certified dealership. Please let me know if you have any further questions.
 

·
Registered
Joined
·
1,897 Posts
Traction control will come on if the wheel position and tire speed think you're entering a skid etc.
You had a tie rod replaced and the steering and wheel positioning would have to be pretty much bang on otherwise that will occur. A dead give away is if the steer wheel is off center driving straight down the road. An alignment would correct that if the mechanic did not take extra care to get i back bang on.

As for the other problems. If depends... without having done any diagnostic, testing, code checks it all guess work.

Checking and cleaning the power ground connection and straps would be a good place to start. A bad ground connection can create weird troubles to sensors and components. Finding them all is also a challenge.
 
1 - 3 of 3 Posts
Top