My Jeep Compass Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Thought I'd update you guys on my Compass. Everything was going really good for a couple of months. I went through rain & snow with no problem & no leaks that I could see. Then yesterday, I took my Compass to the car wash to wash the mud off of it. It did just fine for a couple of hours, but when I came out to start it up to go pick my son up from town, it wouldn't start. Chrysler roadside assistance towed it to the dealer today & they called me later in the day & told me the wireless control module was out. Sadly, this is the second wireless control module it's been through. The service dept. doesn't think it was connected to me washing the car, but the last time the wireless control module went out, it was due to a leak, so why wouldn't it be again this time? So, I think I'm going to throw in the towel on this one. This is the 8th time it's been in the shop since I bought the car in late July of 09. Hopefully, I'll hear back from the general manager of the dealership I purchased it from tomorrow & he's supposed to tell me what I need to do to either get Chrysler to get me another one or give me my money back.
 

·
Registered
Joined
·
222 Posts
Hopefully, I'll hear back from the general manager of the dealership I purchased it from tomorrow & he's supposed to tell me what I need to do to either get Chrysler to get me another one or give me my money back.
GOOD LUCK it took me 3 months and about 50 phone-calls (im not even kidding) to get reimbursed for warranty work of about 1000$. i had to pay for it then fax the invoice...
 

·
Premium Member
Joined
·
1,362 Posts
Sorry to hear you guys are having so many issues with your compass. Mines been quite reliable so far.
I agree, I'm sorry to hear about this, too, and I hope Xtina, that you don't have to throw in the towel and they can get your problem straightened out!!!

- Cherokee
 
1 - 5 of 5 Posts
Top